Quirky Trippers

Hi all,
I just started migration from Smartthings Hub to Hubitat. I can't find drivers for Quirky Trippers.Please advise.

Have you tried pairing them? They may just work with the generic zigbee sensor drivers.

Not every brand of every kind of device has its own driver, many will function just fine with the “generic” z-wave or zigbee driver for that type of device.

No idea if that applies to quirky branded devices, though.

Hello Mark,
Device is pairing with hub but doesn’t seems to be recognized as door open sensor.
Should I try change it from generic type to something else?

If it paired, then try changing the device driver to generic zigbee contact sensor. Then click the configure button, see if that gets it working.

Hello Mark,

Appreciate if you can confirm if the trippers work. have over 26 of them around my house and waiting on our hub to be delivered..


Sorry, I don’t know since I don’t actually own any. I was just trying to help @maxwatkins2010 troubleshoot based on the info he provided. Maybe he can follow up with us on how it’s going based on my last suggestion.

Hi ,
Sorry for delayed response but I have been busy with other projects.
I changed device type Generic Zigbee Contact Sensor and it seems to be working now . I can see it in hubitat reporting change of state and i can use it as open/close sensor.

1 Like

I was able to get mine paired, but can't seem to get them to respond. Did you do anything in particular to get them to display correctly?

Here's the steps I took to get Hubitat to recognize and report the Quirky Trippers:

  1. Remove from Wink
  2. Open the Quirky panel, hold down the tamper switch and remove the battery
  3. While holding down the same tamper switch replace the battery
  4. Initiate the Zigbee discovery and name
  5. Edit the device and set to Generic Zigbee Contact Switch
  6. Hold down the tamper switch and remove the battery (same as step 2)
  7. While holding down the same tamper switch replace the battery (same as step 3)
  8. Re-initiate the Zigbee discovery - it should find the device again and this time apply the correct config

Thanks!!!! That works!

1 Like

Could you clarify a bit please, I'm having issues getting the Tripper to hold the generic zigbee contact sensor setting. I've discovered it, named it, set the generic zigbee contact sensor as the device type, but all I get is a battery status. I have tried the rediscovery but my system doesn't ever pick it back up. Do I need to delete the device first after applying the device type and name before trying the rediscovery? These things have always been a pain to pair or re-pair, even with the Wink hub, whenever the batteries would die.

You do not need to delete, just make sure you do steps 6-8. It took me a few tries to get it but it worked for me and my trippers are working great since.

I had the same experience as @greg. One of my Trippers took two "cycles" through steps 6-8 and the other took 3.

To confirm - the process sushifishpirate mentioned worked for me. Thanks!

Anyone get these working with tamper notifications?

I’ve migrated 7 of them from Wink 2 to HE, but they don’t even show as an option when creating a rule for tamper devices. When I intentionally “tamper” them, there’s nothing in their logs.

Anyone get the tamper working? I see there is a driver for smart things has it been ported to hubitat?

Sounds like Generic Zigbee Contact Sensor driver works.
But you shouldn't have to go through pairing them twice. That's what I would do if the driver didn't have a Configure button, but that driver does. You should be able to just switch to the Generic Zigbee Contact Sensor driver and then press the Configure button, This sends the new driver information to the device.

Pressed configure still no tamper.
I know for a few devices I had to ReDiscover them to pick up the new settings let me try that

I've changed it from generic zigbee contact no temp to generic zigbee contact still no tamper.
I've joined rejoined I've deleted it from habitat rejoined still no tamper.

And this procedure described above didn't work either?