Problems with Zwave after latest successful firmware update

This past weekend I installed the latest Z-Wave firmware. The update went smooth with no errors and normal completion. I have noticed over the last few days a degradation in my z-wave mesh and now have several devices that are not responding. I tried a z-wave repair and all nodes failed. I rebooted and tried repair again same results. I powered down and rebooted and tried again, same results. I installed version and retried, same results. I still have devices that aren't responding. Any suggestions?

Let’s start with the reverting back HE to 2.3.0 - you do realize that that does NOT revert the zwave firmware? Given that ZWave 7.17.1 was tested with 2.3.1 it is probably best to move back up to the latest version.

After doing that, I’d suggest you again shutdown the hub. and remove power at the walll for 30-45 seconds (I understand that you already did that, but…) Once the hub is fully up and everything is settling in, let’s say 5-10 minutes after you get the UI from power up, post a snapshot of the Zwave Details. We might not see anything, but at least we’ll eliminate the obvious and you’ll be able to engage support with that work already completed.


Upgrading the firmware and the degradation of your Z-Wave mesh are likely coincidental. Most likely you have one or more devices that are unresponsive, whether they are going bad, or lingering "ghosts", or simply the hub is unable to communicate with them properly.

Running Z-Wave repair on an unhealthy mesh only furthers the problems, and may cause the entire mesh to go unresponsive. Identifying and addressing any and all devices that are unresponsive is the solution for your problem. As @thebearmay suggested, I would update the hub to the latest release, then methodically examine the Z-Wave nodes to ensure all are responsive. Once confirmed, then you could run a repair: Facts about Z-Wave Repair - #4 by bobbyD

If your problems persist, please send me a PM along with your hub's MAC address and I would be more than happy to check out your hub's engineering log to make sure that you are not dealing with a hardware malfunction.


I was on 2.3.0 when the problem started and updated to 2.3.1 in an effort to fix the problem. Strange thing is that today without any changes the mesh appears to be working much better.

Ok will do. Today everything magically looks better which lends to your theory of a device issue. I’ll dig into that. Thanks


Can you post a copy of your z-wave details page?