Problems with removing Z-Wave node (Old Zooz power strip)

I was not aware of that... I DO have the update firmware button and am now downloading the firmware. I will apply that and see if it works, I had already tried the power off route that you mention. Fingers crossed.....

Maybe you'll get lucky! I know my mesh seems happier in general and node removal has improved steadily in the past few updates. If the update fails, try again but let your hub sit on the zwave details page for 10 minutes or so before attempting.

I keep up to date on the releases and have never done the separate firmware update... Maybe thats the problem.

They come out infrequently generally a couple of months after Silicon Labs releases a new version of the stack. It's not obvious when there is one available but it is posted in the release notes of the platform release.

Thats good info... Thanks for the info...I'll let you know how it turns out

1 Like

The firmware update may take more than one try to complete.

If it falls there first time, try shutting down your hub, unplug and re-plug, restart, go to Z-Wave details page, wait 5m, then start the update.

If you do unplug, and not to beat a dead horse, do it at the power supply not the power cable on the hub as some had flaky connections and you don't want to risk breaking it.

1 Like

Well I applied the firmware update, which appeared to go successfully. Rebooted the hub, then tried to remove the failed device. It will not remove. I will say that my mesh does seem more stabile now. I will try to unplug the hub (from the adapter end) when I get home and see if that helps. I will also wait overnight and try again.

If all else fails the stick worked like a charm.

What stick do you suggest and what software do I need to get?

Pretty sure these instructions still work. The 700 series stick from Zooz should do the trick. The one I have isn't available anymore.

Thanks I just ordered the silicon labs stick $20 at digikey (I have had bad experiences with Zooz). When it gets in, I will give it a go.

Same with Zooz although the new 700 series hasn’t bit me yet.

Yeah that works fine... You will need Simplicity Studio, available from Silicon Labs. It is not appropriately named but it works and the instructions are still valid. And it's free. FYI you have to use the Windows version.

1 Like

Using the stick looks scarier than it is. :smiley:


They do...

Here's the source topic for more context.

1 Like

Hey guys. I followed your advice and got rid of the ghost device using the stick and process above. Just an FYI the Mac Version of their software will not talk to the stick. I used my VMware Fusion Windows instance and installed the Windows version on my virtual machine and it works just fine.

Now that I have the stick is there any way to do zigbee sniffing and any other neat stuff you can do with it?

Thanks again for all of the help.

1 Like

No. It's a z-wave stick. Depending on the stick you got, you can possibly flash it with firmware to act as a z-wave sniffer (or zniffer).

The most common use of this stick is to use it as a secondary control to include, without security, devices that pair by default using S0 to C-7 hubs.

Sorry typo I meant Z-Wave

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.