Problems with HE interface on Microsoft Chromium Edge 84.0.522.50?

I was logging on to my hub this morning and used my main browser, Chromium Edge and for some reason it now only shows the main page correctly. When trying to navigate to any other page they all show in "text mode" with no CSS images or anything like that.

It seems to work fine in the Vivaldi and Firefox browsers.

This is how the settings page looks:

Any idea what the problem is ? It worked in older versions of Edge, but I updated yesterday and this is the result.

No problems here and I have been using EDGE/Chromium since first developer preview. Have you tried to clear your browser cache?

Even though the new Edge is Chronium based, our engineers have not tested it. The supported browsers remain Google Chrome, Safari and Firefox (preferred browser is Google Chrome, and there are some known issues with Firefox, although not as big as the problems we've seen with Microsoft browsers).

If you are using any other browser, your experience may vary.

1 Like

I do in home computer services, and I can tell you I see more issues with Edge than another browser. Avoid it, or at the very least have another browser installed, and when something does not work right in Edge, use a different browser.


Good question. I just cleared the cache for this single site, but it did not help. I'll use another browser for now and perhaps might clear the cache for all.

Since Chromium Edge this is my main browser. It is just so much better than Chrome. The old Edge was not good though.

What version are you running now ? The problem only started after I updated due to the google search bar debacle the other day.

I have the latest version of Chromium Edge and the hub's menu system works fine?

Microsoft Edge is up to date.
Version 84.0.522.50 (Official build) (64-bit)

1 Like

Well.. found the reason for this. Nothing to do with Edge, i had installed an extension called Stylebot to view CSS on the dashboards and that was set to "Readability mode" setting which ends up rendering sites as text only.

So, complete user error on this one. Thanks for all that chimed in :slight_smile: