Problem pairing Ultrapro Switch 39348

I really don't understand how this is this difficult. Actually I do know why this is the difficult. There seems to be no dedicated way to put this switch into pairing mode.

The instructions say, just press and release the top (or bottom) of the switch. Basically turn or turn off the light. Which, yes I tried, but it also seems idiotic to think that this switch will go into a pairing mode every time the load turns on and off?

I also tried the factory reset mode, which says Quickly press On 3 times, then Off 3 times quickly. The led will start flashing. I tried this a number of times, most of the times it didn't do a damn thing, a few times, the led did start flashing, but soon turned solid.

All the while Hubitat was in Zwave Inclusion mode. Most of the time, it didn't detect anything. There were a few times where I got the led flashing that it started bootstrapping, but then apparently failed due to running out of time.

The only way I have been able to pair this switch, is by using the Hubitat App, and Zwave Smartstart QR code.

Am I missing something here? It seems that another "make it simpler" is just making it harder to actually do anything, the switch should have a dedicated pairing mode. I really hate using apps, I shouldn't have to use the app to get a switch paired.

Probably once it is included on the Zwave network, it can't go back into that mode.

You probably should have tried excluding the switch first before trying to include. There are times especially if a switch was on a different hub or if you had a failed pairing where you have to exclude first.

For the most part, I agree. Smartstart is OK, but for whatever reason I am just more used to or comfortable with the manual method. There have been a few times where I and others have had failed pairings with the manual method, but it works perfectly with the Smartstart.

That brings up another thing you need to check, go to your Zwave Details page from the Settings tab. Be sure that there aren't multiple of this switch in that table. There should not be any blanks in the routes column. If there are blanks, you have ghosts that need to be deleted before proceeding.

1 Like

Well this is a brand new switch, and the instructions for inclusion or exclusion is exactly the same, just press the top or the bottom of the switch once.

I did get it to start initializing, but again it timed out. Then I went into the Z-wave Details under Settings, and the switch was actually there, but it wasn't in the Devices. Clicked on Discovery, no change, then had to do a Repair, then it finally came up in Devices. Of course, this switch supports Zwave Plus, so it should have auto-repaired.

I've removed and added a bunch of times now, and the Device Network ID that started at 01, is now at 06. I know I really shouldn't care, but is there a way to get this back to DNI 01? I only have one switch in the system, so it's annoying after all this, that it's at 06.

Can you post a copy of your z-wave details page?

1 Like
  1. Do a soft reset; do not restore a prior database.
  2. Reset the zwave radio.
  3. Factory reset and pair your switch again.

Also, prepare yourself for this. DNIs are non-sequential for virtual and zigbee devices.

BTW, are you sure your DNI started at 01 for your zwave switch? I thought that 01 was the hub and 01-05 were reserved for C-7 hubs? Or do you have a C-5?

2 Likes

If you are wondering what might have happened when Hubitat hub seemingly doesn't do anything, check the past Logs, you should find further details of what happened and what steps you should take next, like " the device needs to be excluded then included again to use securely". But my recommendation for a switch, is to just skip the secure inclusion. Your mesh would be happier without dealing with encrypted messages more than it needs to for locks and garage doors.

3 Likes

I thought it said 01, but I can't say for sure any longer.

I actually tried to do pretty much what you stated (before I read your message), in a slightly different order, I reset the zwave radio, after excluding and removing the switch, then did the soft reset, it didn't seem to change anything. Do you think resetting the zwave after the soft reset is the key?

You mean in terms of DNI?

So you must have a C-7. 01-05 are reserved.

Ok that's really strange, the DNI definitely incremented 2-4 at least, I saw it do that for sure. It's a brand new Hubitat. I also found another older thread that said it couldn't be done. It's annoying, but for now things are working, I'll just live with the DNI addresses, it's not like I'm looking at them everyday.

Just installed some Minoston plug modules as well. These went right in.

If you have a C-7, that is not possible.

2 Likes

Have you done the z-wave firmware update? I agree with @aaiyar the change in DNI like that shouldn't be possible... Very strange. (I was looking for ghosts in your z-wave details page but it's quite clear you don't have any)

1 Like

Don't know what to tell you, I know I saw an id 03 and id04 for sure.

Had you migrated a z-wave network from a C-5 to a C-7? That's one way in which 0x02, 0x03, 0x04 and 0x05 are not reserved by the 700-series radio.

It's currently doing the Z-wave firmware update. What exactly is it doing here? Is this different from the OTA Z-wave updates that needs the app? I figured it would throw an error if it couldn't find a file. I didn't download anything, and I don't have the Device Firmware app installed.

Also, I got another Ultrapro switch, same model, and again I couldn't get it to pair without using the QR code. Not just that, even though there are no ghost items, when I was trying to pair an Intermatic HA09 remote, that wasn't successful, I think it left something behind. I kept getting this device showing up during Z-wave inclusion, saying it found the device, and it was intializing, but never completed. Initially I thought it was the Ultrapro switch, but when I added it using the QR code, it came up as a different ID. That remote has no batteries in it right now, so I don't know what it's detecting.

Nope, brand new C7, I'm switching over from X-10, which I'm wondering now it part of my problem. When I switched over partially yesterday, I could no longer control the X-10 light. The frequencies are completely different, but it definitely is being affected.

Regardless, I definitely saw it incrementing those IDs. On that other thread if I recall, they were seeing similar IDs.

It's updating the z-wave 700 chip in the HE with bug fixes from Silicon Labs..

1 Like

So just got off chat with Jasco, and they said something interesting:

"As for the switch itself, There is not always a way to bypass the QR code scan method. The only way that I have witnessed a load in without requiring the QR would be to add the device under brand ZWAVE and have it load in as a generic device. Now the QR is meant for security and to load in all brand specific data for the switch. When you dont scan the device loads in as a regular zwave on/off that does not have a specified brand tied to it. Hence where the Generic Zwave switch comes in. That is the only step that I know of that could potentially allow zwave load without the QR "

Which might be the cause of the pairing problems I was seeing. Only after I used the QR code in the app, did the Include/Exclude start working correctly. Just another data point here.

Download the Hubitat app