Problem accessing hub after static IP

I configured the hub with DHCP initially and everything fine. Then I changed the IP to static 192.168.1.4 . After that everything went ugly. I am able to access the hubitat from my network via web. However I lost connection from app and via remote administration. When I access remote admin, the hub detected shows the name and the IP. The IP is still the one assigned by DHCP originally like 192.168.1.145
When trying to access via app, the app wants to go to 192.168.1.145 . So basically I lost all chance of communication via app or remote admin.

Thanks in advance for any advise on how to refresh the IP from app and hubitat portal in order to fix this issue.

Check out this thread:

2 Likes

@Coder0420 Change dns to 1.1.1.1 or set a dhcp reservation in your router (preferable)

I've found that the static IP setting in Hubitat to be completely unreliable (sorry, Hubitat company folks). Setting a DHCP reservation based on Mac address has been my only reliable method.

Normally if you set it outside of DHCP range and use 1.1.1.1 as dns it should be fine.

With my hubitat it is impossible to change the DNS IPs, if you replace the list with 1.1.1.1 for instance, it will go back to the default list

You should be able to manually type it in then click save

No, it does not work. Tried in other browsers as well and same behaviour. After replacing with 1.1.1.1 it goes back to the original list. However, if I change it to 4.2.2.4 it allows to keep that value. Basically if you put one of the nameservers on the list it will go back to the full list.

Oh, I see what is going on. If you type one of the listed dns servers it will put the full list instead. However if you put a different one from the list, it will keep the value. Additionally if you put 2 servers in the list, it will keep the value, so a value of 1.1.1.1, 8.8.8.8 will be saved correctly.

Download the Hubitat app