Cannot Register Hub

Brand new Hubitat user here (migrating from Wink). I have my hub up and running and all my devices connected to it, but it won't register. It WAS registered a few days ago when I set it up, but after moving to a static IP it still showed the old original assigned IP address and I saw the message to let it re-cache after 48 hours. After 48 hours today it simply does not show as registered to me any longer. It's also making setup difficult because I cannot use the Mobile App and the Alexa Skill (I'm guessing that's what the hangup is, it always fails to complete the steps after logging and and selecting the correct Hub). I saw in another support article to send an email to support if there were issues, but I haven't heard back yet, so I'm wondering if there's anything else I can try to do in the meantime? Thanks for any insight and help!

Try this:

  1. Use DHCP.
  2. Setup a DHCP reservation on your router for your Hub's MAC address. Do this instead of setting a static IP on the hub.

Reboot .....

1 Like

@user1967 to add to what @aaiyar said, push the reset button on the bottom of the hub for 7 seconds with a toothpick or paperclip (only round hole out of all the square ones) This will reset your network settings on the hub only. It won't disturb anything else. Likely what happened is when you set it for static it had a problem getting to the cloud (have see this happen before) Usually resetting the network settings works. For some reason when it's set on the hub occasionally it won't read DNS correctly and so won't resolve. You can change the dns to 1.1.1.1 from 8.8.8.8 and it should work but changing to DHCP and letting the router control the reservation is a better way to do it.

1 Like

Unfortunatelly my tplink broadband router for spectrum does not have a way to have dhcp reservation. Going back to dhcp fixes the issue, however, static IP should work no matter what. After some diagnostics, I noticed that when static IP is set, the hubitat is no longer detected, but it pings and reacheable via web. I wonder why no one has detected this problem, when this should be a simple network setup. By is behaviour, looks like if the gateway was not setup correctly even though is perfectly fine at the configuration page.

I have seen staff suggest trying 8.8.8.8, 8.8.4.4, 1.1.1.1, 1.0.0.1, 9.9.9.9 for similar issues. Did you try any of these? Apparently the default DNS isn't working for some reason. I believe staff is aware of it, but there likely aren't any updates to fix this until release 2.3.3 comes out.

Tagging @gopher.ny to be sure he has this on his list of things to look at...

2 Likes

Actually that is the default and also tried each one by itself with no luck.

@gopher.ny any suggestions?

Can you PM me the hub id? I can check if it responds to support tool "are you there" requests, which would confirm cloud connectivity (or lack of it).

1 Like

Download the Hubitat app