Power Outage during update

I had the unfortunate experience of being in the middle of an upgrade on my C5 when the power flickered and essentially interrupted that process. The status light on the hub only is blue now, never turns green and it cannot be discovered by the app.

Did I brick the device?
I've searched high and low for doing a factory reset but all options posted online are to do so directly with the hub management not on the hardware itself.

Do I have any options?

Is your Hubitat still being assigned an IP address by your router? If it is, can you reach port 8081 of that IP address, as in:


Also, tagging @bobbyD.


Don't fret excessively. The vast majority of hubs in this condition recover well.

There's a Diagnostic Menu.. reached via your hub's IP address and port 8081 like this: <-- using your own IP address (obviously.)

You'll see a menu much like this:

Screen Shot 2021-07-09 at 8.23.12 PM
Screen Shot 2021-07-09 at 8.23.23 PM

Use the Download Latest Version button and it will start that process. It's not immediate, obviously the time to download is required.


Wow, thank you both. Will check out tomorrow AM and report back progress. Thanks!


I suggest that you put your Hub, switch, and router on an Uninterruptible Power Supply (“UPS”).


+1 to the UPS suggestion. I have multiple ones here running the HE, computer equipment, and other devices.


Good news/bad news: I am able to access the menu through ipaddress:8081, the update successfully downloaded but upon installing it failed to reboot into the typical login menu.

I also tried reverting to a previous version and it successfully reverts but again fails to reboot into the menu and just hangs in the rebooting your device mode.

As for the UPS @StephenH @672southmain, you're absolutely right and I've been meaning to for years. Any suggestions for ones you use? They all seem to have absolutely horrible/mixed bag of reviews.

One example, if you're a DIY type...


My Suggestion(s):

From the Diagnostic Menu, perform a Soft Reset. That will erase the internal DB and then it reboots to just the Platform. Then you can confirm the Platform upgrade worked by again using Restore Previous Version but picking the very latest. I'm hoping that you had two problems, corrupted DB and Corrupted Platform. I'm guessing that the Platform is now good, but the DB is not.

The final step would be booting to the Green (factory new) screen and use the Restore Backup option from the very bottom to restore a backup you saved to your PC.


@csteele Thank you. Followed your directions and the soft reset succeeded but then it would fail to reboot. I then rebooted from the diagnostic menu, the LED changes from blue to red, goes back to blue but then stays at "Waiting for hub to reboot" just like after the soft reset process

As you've read/deduced, Blue LED means the Platform is loading. I don't know the exact percentage, but the first N% is just loading the Platform image from memory and 'unzipping it' for lack of better terminology. Once it's running (certainly by 80%) the DB is loaded, and reconstituted. For a Soft Reset, reboot is done and I've often seen my hub go from 60% to UP with just a brief flash of the progress bar between. Soft Reset should have allowed your hub to skip to the end quickly too, but your description means I'm stuck agreeing with you: The Platform is getting stuck.

I continue to believe that it's recoverable... because in reality, the Computer and underlying OS (Linux) is working. Thus Hubitat Support can probably take a look and pry the wedged item out of the way. :smiley: @bobbyD


Thank you! I will be reaching out to support directly at this point. I appreciate all of your help!