Port closes and Hubitat Hub stop working until power cycle


I am having problems using port forwarding for Hubitat Hub on ports:
I tried keeping these ports open using DMZ, Port Forwarding, Port Triggering, and UPnP. I just cannot get the Hubitat to stay operational because when it cannot communicate it jams and I have to power cycle my hub so it can work back again. This happens every 1 to 3 hours. I do not have an ISP static IP address and I do not want to use it because my ISP wants me to become a business internet user, which will double the cost of my internet bill.
The price of static IP is very high and I do not know if this will solve my issue. Can someone tell me what I can do to keep Hubitat operational? It seems that the ports are closing and only power cycle helps me here. The problem is that it has to be done almost every hour.


As @Brandon mentioned you should not open your hub to the internet!!

What is it you are trying to accomplish 'end goal' ?

I'm sure we can find a way to do it without the security compromise open those ports creates.

1 Like

There are free solutions for getting a VPN server and dynamic DNS running at home if you’re trying to access your hubitat hub remotely.

There’s also built-in cloud access to dashboards if you don’t need the admin interface when not at home.

I get port 8883 blocked and I cannot get my router to keep it open for Hubbitat Hub. I am not trying to do remote access, I need Hubitat Hub to communicate to it servers so I can get it execute a few automatons. For some reason port 8883 gets blocked and I have to power cycle my Hubitat Hub. I do not know how I can stop Hubitat Hub from freezing, I believe it is related to the port being closed.

So far, I have been using the
Kasa Smart WiFi Plug w/Energy Monitoring by TP-Link - Reliable WiFi Connection, No Hub Required, Works with Alexa Echo & Google Assistant (HS110)
this allows me to power cycle my Hubitat Hub over WiFi. I just wish I could keep running Hubitat Hub without having to power cycle it. I even replace it because it was a hardware issue, I also changed my router and my ISP but I cannot get it to work without jamming.

Wait.... So you're NOT trying to access the hub from the outside world? Port forwarding is only for accessing internal resources from outside your network. Such as you hosting something that you are trying to access externally.

If this is the hub's communications being blocked for outbound connections that is completely different. Are you blocking internet access and only allowing certain IP's or ports?

I don't understand why you need a static IP. Maybe you should be looking at a fixed IP address on your local LAN. This will make it so your local browser can find it. If this is what you are trying to to, get into your router , once you know the local IP address (IE mine is for Hubitat) find your router settings for DHCP and manually set the Hubitat hub based on MAC number. That way anytime your hub resets the Hubitat will always be at the same address.
I hope this is what you're looking for.

Someone can correct me if I'm wrong, but I'm pretty sure Hubitat would generally only use ports 80 and 443 (standard for HTTP and HTTPS--and probably mostly the latter) to communicate with the outside world, including its own servers for things like firmware updates and cloud access for Dashboard and OAuth apps (some apps use this for authenticated access over LAN or cloud).

Is there a reason you believe that these specific ports are getting "blocked" (by whom? your ISP? something on your network?) and what they are needed for? Hubitat has a local interface on port 8081, but that's the diagnostic tool (not something you should need on a regular basis, if ever), and my only knowledge of port 8883 is for MQTT, an (unofficial) integration some people use but that is almost always done entirely over your own network (unless you have a cloud provider instead if using your own and a good reason to do so--haven't seen anyone here doing that) and which can generally configured to be any port available. Are you using some community app that requires these ports for specific reasons, and it is it for cloud or LAN? Are you sure it's not a problem with the app? Just adding some more guesses to the pile above since it's not all clear to me, either. :slight_smile:

Sorry man, that makes no sense.
Without sounding condescending I’d say launch YouTube and watch the HE intro videos.
Almost none of what you’ve written seems to apply to Hubitat.

1 Like

Power-cycling is very risky and can (with HE very likely) cause DB corruption. This is a very last resort if not even port 8081 of the hub is accessible. The link is to Soft Reset, in the same location you have emergency reboot if the normal HE web interface isn't available.

What are you trying to do on your router? The Source port of a TCP connection is in most cases NOT static and will change, if you're trying to have rules on your router set so that the HE hub can only communicate with the Internet over specific ports you need to control that on the Destination port number. NOT Source port. With that said, please explain in more detail what it is that you're trying to accomplish.

As @bertabcd1234 is saying, port 8883 is MQTT. Which Community Apps and Drivers are you running?
Port 8883 could be blocked by your ISP further downstream, which country are you in?

I don't think it can be said enough, for Outgoing communication from anything on your network, port forwarding is NOT needed and is not something you should setup. If you use a normal domestic router the default settings will let your HE hub communicate with the Internet without any special settings.

Going back to what I first mentioned regarding power-cycling, it sounds like you've done plenty of power-cycling, your DB is almost certainly corrupted by now. Backup your DB and do a Soft Reset and stop doing power-cycling...

Yes, I will try this. The problem is that when my Hub jams I am not able to access it nor use the port 8081 so I can use commands to troubleshoot.

If 8081 is not accessible it sounds like you could have another issue, do you have a separate network switch you could plug in your HE to instead of directly to the router? If you're still using the flat network cable, switch to a good quality one if you have.

You could also have a faulty power supply, do you have another micro USB power supply with more than 1A you could use?

If you have the patience, only change one of these at a time and see how it goes.

1 Like

Sure, I will try step by step. I will let you know when I get this problem solved.

1 Question;
Is this a brand new HE Hub you're working with or one that has had Apps, Drivers and Rules running on it ??


Yes. I got this HE back in January

I did change the usb power cable, the Ethernet cable and the location.
I still have the issue!

Not just the cable, the power supply, these things do fail at times, and power failures can look like the issues you have.

Change location? What do you mean?

Sorry man, this doesn't really answer the question clearly.

  • As you got it in January, I'd say NO it is not brand new
  • As you got it in January, I'd say YES you have probably loaded Apps, Drivers and Rules.
    See how the answer is not clear ?

Could you have created a Rule with a loop that is jamming up the HE hub ??
How about disabling some of the Apps you've loaded or RULES you've created, until you regain stable control on the Hub

I have change the power cable, the Ethernet cable, the power adapter... I still have jamming issues, I swap my HE back in January and I this problem was not fix. It is not a hardware issue but a network issue. What else can I do?