PoE and the C8 (with extensive testing)

You are powering them with POE right? I tried my tests with a portable power station, and another USB battery pack as the sources. I wouldn't think they would have any impact on the device's output, but I could be wrong. I definitely want to test more, just haven't had tons of time lately. I picked up one of the Procet POE adapters, I'll try with that and a USB wall wart and see if I get similar results.

The device was my phone. Seemed to be a minimal interruption, but enough to get the battery indicator to flash quickly off and back on. Obviously not a problem for a phone, but I assume it would be long enough for the hub to completely drop, or potentially cause larger issues (database corruption, etc)

The battery was at 100% as I had just charged it prior to testing. I'll probably drain it down 20% or so and try again to see if that makes any difference.

Very interesting your results are different than mine. I could have gotten one with a defect of some sort, or they changed the internals on us. Will be interesting to see what further testing brings.

A phone has a different behavior than the hub. A phone will attempt an active usb negotiation for a power level, whereas the hub is “dumb” and just uses the standard 5V/1A. In other words the phone may perceive a power event that the hub would not. I would test with a hub before reaching a final conclusion.


I will try to remember to check one of mine tonight. I have one hub that is completely backup at this point (now that I have my C-8 Pro) so it does not have any devices or such...

Figuring on:

  1. Unplugging power supply (PoE) from battery for just a couple minutes
  2. Plugging it back in
  3. Unplugging and letting it drain
  4. Plugging it back in

That should give 4 different scenarios to see if the hub is impacted. The drain one will be overnight of course (since the hub will have no way of knowing what is left).

#1 is a failure. The one I was testing (it might not be all, but this is one of the newer ones I bought) powered off for a moment when unplugged from power. It powered back on pretty quickly, but the Hubitat still lost power and had to reboot. This should not REALLY be a problem for the Hubitat (and it was back up pretty quickly) but it is not what I personally want. I am going to remove my link in my earlier post.
#2 is ALSO a failure. When plugged back in the battery again shuts off power (even shorter than when unplugged) but it is still enough to power cycle the Hubitat.

No sure there is any point in testing for #4.

So in the end... these (at least the newest ones) are not as useful as I thought. The Hubitat will power cycle at the beginning and end of a power failure. It WILL keep it going for some time if the power failure is longer than a few minutes so it is not completely useless.

Sorry folks.

1 Like

So I had a weird issue with the Procet PT-PTC-AT. I bought it because I was having the issues with the C8 using my prior PoE adapter that I had been using for years with the C5. When I used a standard USB C to USB C cable, it would not power the hub at all. That cable worked fine to power my phone but not the hub. So I used a power only (no data) USB C to USB A cable, then used a USB A to USB C adapter and it powered right up (I had those items laying around, other ways may have worked too). Other than that the Procet adapter has fixed my z-wave issues.

Thank you so much for all of your testing and figuring this out.

Wow, man
Thanks so much for sharing the Voltaic V25/V50/V75 IoT battery link.

I've been thinking about adopting a small solar panel to my window contact sensors to eliminate battery swaps and these guys have the solution.
Thank you.

I bought the Procet 100Mb PTC-AF-5V from Amazon, but it didn't work for me. My POE source is a TP-Link TL-SG108PE switch and the hub is a C-8 Pro.

My Z-Wave network started going haywire, with the main symptom being that old non-Plus devices were not responding or very slow to respond. Newer devices (Z-Wave Plus) seemed to mostly be working, but if I sent a command to an older device first, nothing would respond for a while. Multiple Z-Wave network repairs showed failed nodes.

I just plugged the hub back into the supplied power brick and did a repair and everything is back to normal. It looks like this splitter either has enough variance in samples to not always work, or doesn't work with this TP-Link switch.

I'm sorry you're running into issues. I didn't have a C8 Pro to test with, but the symptoms sounds very much like the general lockup failures I saw on the C8 with the "bad" splitters. I would return that splitter for sure. If you do end up exchanging the PTC-AF-5V another of the same unit, please post your result. I am curious to know if was simply one bad unit (or not).

The best of the best that I tested was the PT-PTC-AT. Unfortunately the price on Amazon is back up to $55. It was down to $27.50 when I went on vacation.

You need another vacation.


Forgot to share this info - I have had one of these in use w/my C8, and it was on my C8-Pro until recently and I never had any of the obvious issues w/Z-Wave while using it. I bought it in 9/2020 from Amazon, current price is 2/$19. So maybe an option for those who are on a tight budget and need to power two C8/C8-Pros?


I replaced it w/one of the PT-PTC-AT units purely for FOMO reasons. :slight_smile:

I'd hate to send it back to Amazon and see it end up in the landfill. I may try swapping it with a UCtronics unit that I'm using to power a Raspberry Pi since it seems like everyone's environment may yield different results. Or I may just leave it on the power brick. I don't really need the POE where I have the hub. I was using it just because it would allow me to power cycle the hub remotely from the switch.

1 Like

I wouldn't waste any more time or money on UCTRONICS PoE splitters with the C8/C8Pro. I have verified poor Z-Wave performance now with two different UCTONICS PoE splitters. YMMV, of course...

That is the splitter that I had that was giving me all the issues with my C8, worked fine for the C5 though. I went with the Procet PT-PTC-AT and that solved everything. It seems like everybody's setup is a little different so YMMV.

Yup - definitely a YMMV, and we're never going to track down all of the variables that result in it working for me across both C8/C8-Pro and not for others.,,though I'm not sure that anyone specifically reported on the model I used.

Other unknown (unless you open and look) is likelyhood of changes to the PCB included in splitters over time. :slight_smile:

A note on USB cables

So, something I've learned since the original posts is that I really lucked out with the cables I used.

When I started testing, I needed a couple of USB-C cables to loop in the USB meter. It was shortly after the holidays and my daughters had received iPads as gifts, so I grabbed the two charging cables that came with the iPads. I did my testing, and life was good. When I finished, I ended up using the iPad cables to connect the hubs to the splitters with the intention of replacing them later.

A couple of weeks ago, I got around to replacing the cables. I ordered a couple of shorter cables from Amazon... and was surprised to find that the hubs would not power up via the new cables. A little surprised, I ordered another set from a different manufacturer. These didn't work either. The abyss of another project loomed...

I ended up trying 15+ sets of cables, ranging from big names such as Apple and Anker, to inexpensive no-name Amazon only brands. Some worked, but the majority did not. Interestingly all 3 types of Apple cables I tried worked, whereas all 3 types of Anker cables did not work. Some UGREEN cables worked, some did not. No easy answers.

I'm not going to report on all the cables I tried individually as I think cables change too rapidly to make a list of much use. The take-home is that if you try a cable and the hub doesn't power up but a phone will, try a different cable.

FWIW, I ended up using these cables from an unknown brand (at least to me) because they worked, were shorter, braided and black. YMMV.

[And in case you are going to ask... my guess is that the hub doesn't draw enough power to get some of the chips in the cables to do their thing.]


Bizarre...I just came to the topic and was going to report similar results...

I'm using the top of the line (at least most expsensive) splitter, the PT-PTC-AT version.

I initially set it up right next to the C8-Pro it's powering, using the same cables I had used w/my previous splitter. The previous splitter had worked fine, as I have noted I really only upgraded due to a little bit of FOMO. :wink:

Then I did some unrelated (I thought) clean-up around the hub's location in the office, and suddenly my wife decided she had a better place that I should move the splitter to for aesthetic reasons. :slight_smile: The new spot was about 6' from the original location right next to the hub. So I needed a longer USB cable. I initially tried a cable I had in my collection of cables and had used w/my phones and other devices for years w/out issues. The hub started up fine, but I began getting odd/intermittent delays in motion lighting>Z-Wave switches, and my Z-Wave blinds acted up.

I replaced the cable with an Anker cable and things have been back to normal since (maybe two weeks ago?), w/everything working normally/reliably.

So my experience echoes yours, there are definitely some potential cable issues you can run into. Interesting that the Anker cables you tried didn't work for you, Denny. Did you try the one I linked to? I assume probably not, unless you also located your splitter quite a a ways from the hub.

I should note I have a slightly "odd" configuration - I have a SonOff micro-USB switch between my POE splitter and the hub, so I can power cycle it remotely. That has been in place for years (since 2020) w/my old POE splitter and the SonOff has never caused any problems in that configuration - Z-Wave worked w/out issue w/the SonOff and C7, C8 and C8-Pro w/my old POE splitter/short cable.

1 Like

All the cables I tried were USB-C to USB-C, with the PT-PTC-AT.

1 Like

I am finding those USB switches very useful for all the USB lighting decorations that are available nowadays. I think we have 6 of them so far... Soon I will have to start checking if they go on sale.

1 Like

Yup, they are small, reliable, and pretty cheap. A nice find. :slight_smile:

Hmmm. I wonder if that was the cause of my initial failure.....

Technology...meh. lol



All the A > C cables should in theory work because there is less tech involved in sending the power. To put it simply, it just sends 5 volts all the time. Other people have reported issues using USB-C power supplies where the hub seems dead, and then an older A supply will work fine.

So probably the most reliable option would be a verified splitter with either an integrated C male cord, or if it has a female receptacle to plug your own cord in, the A style would be more reliable in the case of this hub, since it does not do any sort of USB-C power negotiations.

Of course if you already have a working C to C setup, there is no reason to change it. The only issue with it is if you change your cord you may get mixed results.

1 Like