PoE and the C8 (with extensive testing)

You are most welcome


I use Ubiquity extensively and have one particular switch which is 24 port POE 500W.
It and my Cloudkey and router are UPS backed as a mini network section that stays up during a power outage. I have I guess 14 POE devices on this including several HE hubs and they have always worked well. I like the individual automated on/off control I have from my HA system, to load shed if needed.

However my C8 and C8Pro are not on this switch because of no POE splitters with appropriate type C connectors. They are powered from a multi output type C PSU.

Now I have great beliefs in POE devices especially if they can be individually home automation switched. I now find the desire to get some more type C POE splitters but Denny’s favourite is very expensive in the UK Ahhh Amazon US will ship to UK so here we go


Ok. I'm completely stumped.

I bought the PT-PTC-AT and connected it to my Ubiquiti Flex, and C8 in place of one of the UCtronics models, and the effort was an unmitigated disaster. The extractor utterly failed to power up the Hub.

I tried it in my in-wall hub, so I'll next try it with a C7, or C8 pro. Someplace easier to work in as well.

I've also ordered a couple of the 5V 100Mbit versions.


Sorry to hear. Perhaps a bad unit? Will it power your phone or tablet?

1 Like

Good suggestion.


Cables are good. Took it down to my utility area, connected it to my USW-24-POE, plugged in a C8-Pro, the POE extractor, using the same USB cable, the same ethernet cable (well 1 of them --- the other is on the older C8), and...it works.

Dunno what was going on yesterday, but it seems to work just fine now.

Thanks @dennypage.



I ordered one of these power banks and have just gotten around to playing with it. I have noticed, when "mains" power (the source in this case) is pulled, the devices connected lose power momentarily. I tried all combinations of ports, and all of them had the same result. Mains - Micro USB, Device - USB C or USB A. Mains - USB C, Device - USB A. It happens when power is removed, and also when power is restored.

Might not be a problem for those using it on some sort of UPS. Though, if someone plans to use this with the hub included power supply, it really won't get them any benefits, since the hub will get power dropped if the power goes out and dropped again when power is restored. Though, if someone has a POE supply, which is on a UPS, and uses this as a stabilizer, then I see no real issues using it for that use case.

Maybe I received an updated model where this happens, and the older ones don't drop power? Not sure, and would be nice to hear if others are seeing the same issue. For the whopping $16 I paid for it, I'll just keep it or give it to my wife to use.

Sort of want to pickup a Voltaic Systems V25 (if it ever comes into stock on Amazon) and test that out. If it doesn't happen to drop when the source drops, then it might be the better option, at least in terms of keeping the hub alive as long as possible without interruption.


Much better.

I picked up 4 of the Procet 100Mb PTC-AF-5V and I'm impressed.

They look nice and seem solidly built. The LED power indicator is nice, and beats having to try to look at the port lights to be assured theres's power.

This model came with a USB C to Micro-b adapter, which was awesome for the C5, C7 & Fingbox, while the C8 happily consumed power from the USB C directly.

My only complaint is the pigtails are just a wee bit too short. But I made it work!

Great Stuff @dennypage thank you!



You are most welcome. I’m glad they worked for you.

Weird. Mine are all pretty recent and do not seem to be doing that. I did notice that I had to press the power button to get them going the first time but have not needed to since. I have not tried running one to "empty" yet though to see if it comes back on automatically when it starts charging again.

You are powering them with POE right? I tried my tests with a portable power station, and another USB battery pack as the sources. I wouldn't think they would have any impact on the device's output, but I could be wrong. I definitely want to test more, just haven't had tons of time lately. I picked up one of the Procet POE adapters, I'll try with that and a USB wall wart and see if I get similar results.

The device was my phone. Seemed to be a minimal interruption, but enough to get the battery indicator to flash quickly off and back on. Obviously not a problem for a phone, but I assume it would be long enough for the hub to completely drop, or potentially cause larger issues (database corruption, etc)

The battery was at 100% as I had just charged it prior to testing. I'll probably drain it down 20% or so and try again to see if that makes any difference.

Very interesting your results are different than mine. I could have gotten one with a defect of some sort, or they changed the internals on us. Will be interesting to see what further testing brings.

A phone has a different behavior than the hub. A phone will attempt an active usb negotiation for a power level, whereas the hub is “dumb” and just uses the standard 5V/1A. In other words the phone may perceive a power event that the hub would not. I would test with a hub before reaching a final conclusion.


I will try to remember to check one of mine tonight. I have one hub that is completely backup at this point (now that I have my C-8 Pro) so it does not have any devices or such...

Figuring on:

  1. Unplugging power supply (PoE) from battery for just a couple minutes
  2. Plugging it back in
  3. Unplugging and letting it drain
  4. Plugging it back in

That should give 4 different scenarios to see if the hub is impacted. The drain one will be overnight of course (since the hub will have no way of knowing what is left).

#1 is a failure. The one I was testing (it might not be all, but this is one of the newer ones I bought) powered off for a moment when unplugged from power. It powered back on pretty quickly, but the Hubitat still lost power and had to reboot. This should not REALLY be a problem for the Hubitat (and it was back up pretty quickly) but it is not what I personally want. I am going to remove my link in my earlier post.
#2 is ALSO a failure. When plugged back in the battery again shuts off power (even shorter than when unplugged) but it is still enough to power cycle the Hubitat.

No sure there is any point in testing for #4.

So in the end... these (at least the newest ones) are not as useful as I thought. The Hubitat will power cycle at the beginning and end of a power failure. It WILL keep it going for some time if the power failure is longer than a few minutes so it is not completely useless.

Sorry folks.

1 Like

So I had a weird issue with the Procet PT-PTC-AT. I bought it because I was having the issues with the C8 using my prior PoE adapter that I had been using for years with the C5. When I used a standard USB C to USB C cable, it would not power the hub at all. That cable worked fine to power my phone but not the hub. So I used a power only (no data) USB C to USB A cable, then used a USB A to USB C adapter and it powered right up (I had those items laying around, other ways may have worked too). Other than that the Procet adapter has fixed my z-wave issues.

Thank you so much for all of your testing and figuring this out.

Wow, man
Thanks so much for sharing the Voltaic V25/V50/V75 IoT battery link.

I've been thinking about adopting a small solar panel to my window contact sensors to eliminate battery swaps and these guys have the solution.
Thank you.

I bought the Procet 100Mb PTC-AF-5V from Amazon, but it didn't work for me. My POE source is a TP-Link TL-SG108PE switch and the hub is a C-8 Pro.

My Z-Wave network started going haywire, with the main symptom being that old non-Plus devices were not responding or very slow to respond. Newer devices (Z-Wave Plus) seemed to mostly be working, but if I sent a command to an older device first, nothing would respond for a while. Multiple Z-Wave network repairs showed failed nodes.

I just plugged the hub back into the supplied power brick and did a repair and everything is back to normal. It looks like this splitter either has enough variance in samples to not always work, or doesn't work with this TP-Link switch.

I'm sorry you're running into issues. I didn't have a C8 Pro to test with, but the symptoms sounds very much like the general lockup failures I saw on the C8 with the "bad" splitters. I would return that splitter for sure. If you do end up exchanging the PTC-AF-5V another of the same unit, please post your result. I am curious to know if was simply one bad unit (or not).

The best of the best that I tested was the PT-PTC-AT. Unfortunately the price on Amazon is back up to $55. It was down to $27.50 when I went on vacation.

You need another vacation.


Forgot to share this info - I have had one of these in use w/my C8, and it was on my C8-Pro until recently and I never had any of the obvious issues w/Z-Wave while using it. I bought it in 9/2020 from Amazon, current price is 2/$19. So maybe an option for those who are on a tight budget and need to power two C8/C8-Pros?


I replaced it w/one of the PT-PTC-AT units purely for FOMO reasons. :slight_smile:

I'd hate to send it back to Amazon and see it end up in the landfill. I may try swapping it with a UCtronics unit that I'm using to power a Raspberry Pi since it seems like everyone's environment may yield different results. Or I may just leave it on the power brick. I don't really need the POE where I have the hub. I was using it just because it would allow me to power cycle the hub remotely from the switch.

1 Like

I wouldn't waste any more time or money on UCTRONICS PoE splitters with the C8/C8Pro. I have verified poor Z-Wave performance now with two different UCTONICS PoE splitters. YMMV, of course...