Please help with Kwikset 888

Received Kwikset 98880 but unable to use with HE

It says Z-wave plus, but pairs as 'Device':

  • deviceType: 3
  • zwaveSecurePairingComplete: true
  • inClusters: 0x5E,0x72,0x98
  • deviceId: 1345
  • manufacturer: 144

Tried factory reset, manually changing device type to Generic Z-Wave lock, pairing 1ft or 3 ft away, nothing...

Please advise.

  1. this takes patience... you may have to do this several times until you get complete pairing
  2. are you pairing securely? i.e. please make sure the following is set:
  3. this takes time to pair - the hub and the lock should be together for at least 1-3 minutes after it says "paired"
  4. Do you have a "beaming" zwave plus device nearby? (for keeping it paired)
  5. Should eventually show the following:
  6. KEEP CALM AND CARRY ON! (take a deep breath)
1 Like

I have found that getting away from Kwikset locks in general tends to be the best route no matter the version UNLESS you are using the Zigbee version.

Benefits: No more issues with reliability, have a bit more hardened locks (Kwikset is very easy to pick), and of course better looking lock.

  1. Thanks

  2. Yes, tried both locks/garage and all secure

  3. Nothing happened in the logs after

  4. no, but zooz zen27 is coming

  5. nothing happened in the logs after:
    infofingerprint mfr:"0090", prod:"0003", deviceId:"0541", inClusters:"0x5E,0x72,0x98"
    debugbuilding fingerprint for unknown Z-Wave device...
    infoZ-Wave Discovery Stopped
    infoUnknown Z-Wave Device Discovered
    debugconfigure() called...
    infoInitializing Z-Wave Device : 06

  6. thanks, I am, there is still hope left :slight_smile:

this is cheap enough lock for the door to garage, only reason to have it smart/zwave is to control auto lock at night. If someone gets into garage they can pry open any door (and other safeguards would notify my, hopefully). Besides, when I was researching I've seen some reports of unreliability of some schlage and some yale as well, unfortunately.

So far biggest hope is for zooz dimmer beaming

The Zooz should only help keep it paired, not get it paired.

Hmm... it does appear that there are some clusters missing! (0x73, 0x7A).
Either you didn't give the lock enough time to convey all the info to the hub,
perhaps the lock is in a "strange" state so that it isn't sending everything to the hub
perhaps the lock is defective, and that's why it isn't communicating everything to the hub.

Proceeding on the second possibility, may I suggest that you do a "factory reset" on the lock, and then go ahead and try to pair again.
From the user manual: (sorry for the small size)

I just got an 888 from dailysteals for 80 bucks. It's a real stinker. Tried with both smartthings & hubitat. The radio in the lock is very weak, even 3 ft from the hubs.
Does not report anything on either hub, but does pair, but that's it. zero control, zero reports.

It's going back , not worth the savngs. Locks need to work. My schlage be469 is perfect over 14 months

Hence why I stated every/any one should abandon Kwikset Zwave locks. They are horrible devices and the new basement prices explain this too. I had two Kwiset 888 and had reliability issues on ST. When I moved to HE they dropped ALL the time. I even sent one of my Kwikset 888 to Mike Maxwell and he was able to figure out the fingerprint but not why it would fail when deployed.

Again...if you have the opportunity to return it you can get a Yale 110 for $5-10 more. I have had zero issues with the Yale device working and the battery life with rechargeable batteries is amazing for how active my household is going in/out and the house autolocking every 2 min.

1 Like

This is the one that I have (from amazon):

I know that this may sound strange, but I've never had an issue!
Is this exactly the same product?
It paired first time, has never dropped from the mesh, and has always responded immediately to commands...
I don't have any zwave extenders nearby, but I do have some Leviton zwave plus switches nearby.

To be honest, I simply don't understand how my (and some others) experience could be so good with a product, and some others (such as yourself) be so bad. Perhaps there is "uneven" manufacturing, and some products are good, and some are bad. I just don't know.

1 Like

No idea but I had two 888’s and both did the same thing. One was only 10’ from the hub.

Eh, each to their own. My Kwikset 916s and 914 (zigbee) are reliable, status is 100% correct 100% of time, and look just fine to me.

My Kwikset zwave plus modules were 100% reliable on SmartThings too, for the record. It is just HE that seems to have issues with them...

1 Like

Zooz dimmer works great, no dice with the lock.
Got second lock to try (first was new 80$ from deal, new is 888 refurbished from amazon), exactly same behaviour. Going to give one more 888 (new from amazon) a try, if not - all going back

If you do manage to get them all working you could set up something like you see in some comedies. Someone goes to answer the door and there are 3 or 4 locks and they need to open each of them. You could have it automated and they all open sequentially or randomly. You choose.

1 Like

Are you sure that the Smartcode 888 that you have is the one that is zwave plus?
I notice that there are models that are called the same, but are not zwave plus
(if you have cluster 0x5E that indicates plus)
I'd also like to point out, that my Smartcode 888 has the following clusters that yours did not:
So, it's not really the same device!

Did you do a factory reset, as per the diagram?

Also, I know that others have had some success:

  1. putting a Aeotec Repeater nearby
  2. Using the Reliable Locks function

Mine having been working like a champ for over a year now. Nothing wrong with zwave as far as I can tell.

1 Like

I am aware of at least 3 different firmware revisions for this lock. I came across that info while doing research as to why my lock was a piece of shit. Never reports and won't respond to commands, on both ST and HE. It paired just fine, and I even excluded it several times.
It was a refurb from dailysteals.
Mine is going back

Do you know how I can find out the firmware level on my lock?

Is a difference in firmware responsible for the additional clusters that I have?

It's printed on the circuit board behind the batteries, towards the left side when looking at batteries.

Heads up, 3rd lock, looks exactly the same as 2 before, but ordered new from amazon paired in few seconds from 10' away and works fine (get codes, lock, unlock close up or 20ft away).
First 2 going back ...

Will check revisions in the morning.

As per @Rxich, what's your firmware level? I couldn't see mine, because it's already up. However, is this your exact model: