Please help me understand light/switch timing issue

Hi there! I'm new to HE and pretty novice at automation in general. I used to have a staples hub (it was free, please don't judge!). When they pulled the plug on the servers, I learned the importance of local control. I was out of the game until I got in on the Black Friday HEC7 deal this year and have slowly started setting up some basics using my parts from the Staples days. While I enjoy tinkering (and have dreams of mimicking some of the examples of what I've seen in the community forums), my most important thing is high WAF. Which leads me to my main question...

I've been playing around with a couple of Hue lights (with bridge) in the master bedroom, a nightstand lamp and a floor lamp. I also have a GE Enbrighten Zwave smart switch. Originally, I had wired it so that the switch controlled the outlet the lamp was plugged into and then used HE to send a button command to the nightstand. However, in testing, I ran into some situations where the relay in the switch would simply stop responding for a minute, even though the device log in HE showed that the switch was physically pushed. (Specifically, if I turned the switch on, then held it off, it would stop responding). I rewired the switch so that it's always hot so now I have an old-school looking button on my wall. Using Basic Rules app, I set up six commands:
button 1 press = floor lamp on
button 2 press = floor off
button 1 double tap = nightstand on
button 2 double = nightstand off
button 1 hold = all on
button 2 hold = all off

These all work consistently. However, my issue is with the timing. The single button push takes about 3s to deploy. The double push is about half that and the hold responds after about .5s. I've tried all sorts of troubleshooting, so I know it's not the bulbs or the fixtures. And, obviously, the bulb CAN change quickly -- as it does when I hold the button or activate the bulb or switch through the device list, so I can't imagine that it's the zwave network.

My best guess as to what's happening is that there's a delay to make sure that it really is a single press and not two. Simply put, is there a way to get the single-button push to respond more quickly? I really don't want to have to tell my wife that the choice is between hitting the switch once and waiting a few seconds in darkness or needing to double-click or hold so that the light comes on. It's supposed to be MORE convenient than a dumb switch and bulb!

Thank you!!

Also, yes, I'm aware that this is the epitome of first world problem. :innocent:

The most likely explanation here is that your z-wave mesh is not very robust. As you add more line-powered z-wave devices, the mesh will strengthen and response times should improve.

This article may be helpful:

https://docs.hubitat.com/index.php?title=How_to_Build_a_Solid_Z-Wave_Mesh

2 Likes

Thanks so much! I have another switch that I'm going to add to beef up the coverage, so I'll see if that makes a difference. However, that doesn't make sense to me because the "button hold" command works quickly. That said, I know pretty much nothing about how ZWave or HE routes these commands. Would there be a reason why a single button press is processed slowly but a button hold happens quickly? This is consistently happening every time I try the automation.

@aaiyar is right - lots of delays like this end up being mesh issues and you should definitely check there... also for zwave ghosts.

But to your point also, why the difference between a push vs a double push? That might be a function of the device or driver. You could look at the events log from the devices page and try to correlate when the device/driver are registering events vs when you're physically pushing the button. If that's where the delay is, not a ton you can do about it unless there's a community-supported driver out there. What kind of button controller is it?

3 Likes

Well, you nailed it. At first, I thought the button presses were being read instantly because the log timing synced with my watch. Then, I realized that the Hub clock is 3s behind mine. The holds register in about 1.5s as do the double taps, so it seems like that's indeed where the issue lies. I'm going to email Jasco if there's a firmware update (as well as how to do it -- any insight?). How do I search to find community drivers? Is it through a hubitat app? I also have a second switch of the same brand, so I'll see if it performs the same way. If it doesn't, I'll exchange.

Interestingly, while I was doing the logs, I was able to recreate the "lockout" as well, which I hadn't seen since wiring the switch as always hot. It appears that this switch ignores commands for a little while if you hold it down for around 5s. Something else to email about, I suppose.

Thanks so much!

Jasco doesn't provide firmware updates.

You may wish to try this driver:

4 Likes

@aaiyar Wow, thanks so much! HE community is amazing!

1 Like

Sorry, can't be much help on the switch itself. I went Lutron about a year ago and never looked back.

Thanks for the assistance. I think I'm going to change my plans. I see smartesthome is having a sale, so I'm going to buy some Zooz switches. The Enbrighten one is technically controlling an outlet which the Zooz switches say not to do, so I'll try the community driver and see if that helps. I chatted with Jasco today and they told me wrong information and basically said it was a Hubitat thing. So I think I'll be avoiding their products when given the choice

@aaiyar @brad5 I realize I ghosted the topic. As an appreciative follow up -- and as a heads up to anybody in the same boat that stumbles across this -- the community driver is the solution. There's a parameter "enable alternate exclusion" that even makes note about the status report time. Turning this parameter on makes the light respond pretty much instantly.

Thank you thank you!

2 Likes

Download the Hubitat app