Platform update - safe?

I believe I read somewhere that .127 was problematic, I see .128 is available, safe to use? Any issues?

I installed it yesterday on my C-5s and C-7 - all good so far! :crossed_fingers:


I have an addon question. At some point I'm going to have my house done enough to not be looking at this thing every day. (I mean, maybe lol) If I miss several updates and then decide to update can that ever be problematic?

Even if it was if you do a backup beforehand you can always restore. The only issue I could see is with the He's ZWave Firmware. Dont think you can revert back from that.

I recently upgraded someone's house from 2.2.5 all the way up to 2.2.7.
No issues.
I find that this is a major Hubitat improvement over some other products which have been known to "break" prior releases.
Many people here run on old releases without upgrading, because they don't need the upgraded functionality.


Also I'm thankful we can just upgrade to the latest and greatest without any intermediate steps..

1 Like

I had this a while back, I was running 2.2.4.something for a LONG time (not broken, why fix it).

When I eventually updated to 2.2.6.something there were a load of issues, not insurmountable but a pretty long triage list to work through afterwards. Some stuff was immediately evident other stuff took a few weeks to materialise and some head scratching.

One problem I found was that searching the forum for answers was difficult as I was looking for "issues" that most other people had encountered and resolved months ago. Lately I've been making sure to update periodically, at least every few months, although I usually wait a few weeks after each release first. That way any common issues are fresh on the forum and easier to spot!

1 Like

I did it last night only to wake up this morning to get started screen. Only my main hub though. Not my other 3. Quick restore and I was perfect again other than that gut feeling of not knowing what happened.

The restore feature is such a powerful tool in the HE arsenal I think. That and the soft-reset have really helped navigate the growing (and learning) pains...


Having a bad day .... can everybody still get to the diagnostic menu on ?

I just updated one of my C4's and now IP:8081 takes me straight to platform switch:

Works on both my C-7 and my C-5.

1 Like

No idea then .... this was actually a spare "boxed" C4 I had on the shelf. Nothing on it, was running up until a few days ago. Updated it to and then wanted to factory reset it so I could swap it out with another (potentially) failing C4.

Tried rebooting, different browsers, private browser window, different PC's / laptops / phones / tablets. Won't have it ..... IP:8081 just gives the platform switch thing.

Seems this was caused by an outdated diagnostic tool version. Running IP/hub/cloud/updateDiagnosticTool caused an update and can now access the full diagnostic tool. Strange though since this C4 I've been powering up every few months for a few days to keep up to date with firmware, then boxing it back up again. So would have thought it would have been up to date.

1 Like

What are you referring to?

1 Like

Ah I missed that. Didn't even notice when .128 was released yesterday it had jumped from .126.


1 Like

Same thing happened to me. After catching my breath from a brief panic attack :woozy_face: I was able to restore from the in-flash backup and everything back to normal :sweat_smile:

Same here, about to restore, fingers crossed.

I had that happen on .126. When i reviewed the logs there were signs of a database problem.

Same here. The database should not have gotten corrupted through the upgrade but it did. The strange part is it worked for about ten hours after the upgrade before the errors overtook the hub.

Has something changed with Maker API? I used to be able to pull up the following URL and get a result of the values for the devices.:

http://<Internal IP>/apps/api/1153/devices/

Now I get the following response:





I can still query individual devices and get them to work, but I was using this method to scrape for Prometheus/Grafana. Everything worked this morning until I updated to .128.