Philips hue dimmer switch v2

This one was a challenge (for my small brain), I bought a philips hue dimmer switch v2 and added it no problem, set up the buttons for lights, job done. Shortly before adding it I updated to the .123 firmware version where we seen the bugs when going to the devices page. Initially I thought this was something I had done so I restored my HE to the previous backup which was prior to me adding the new dimmer switch.

Anyway, one thing led to another and I was distracted from adding it again that day, until last night. I tried to add it and it paired successfully however when I pressed a button nothing was shown on the device page. I thought this was strange so I reset it and removed it then added it again. Nothing was working but what I did notice was the button LED was continuously flashing orange like it was trying to pair.
Without doing anything I tried pairing a zigbee device again and it showed up again as a previously added device, when I selected it and went to the device page I could see the buttons pressed and the green LED flashed as I pressed the buttons. After about 10 seconds the green LED (which flashed on button press) turned back to flashing orange every second and no button presses shown.
I repeated the above and the same thing happened, the button presses appeared for about 10 seconds then nothing.
I tried all the ways to reset the device but the same thing continuously happened - the button controller kept jumping back into pairing mode after 10 seconds.
It worked for 10 seconds then just wouldn't stop returning to pairing mode :frowning:

Anyways, to remedy this (I didn't think it would work but it did to my surprise!), after I paired the device to HE again and proved the buttons worked I removed the battery within about 6 seconds, installed the battery again and hey presto it stayed connected and works every time :slight_smile:

I just thought I'd share in case anyone else has a similar issue or if anyone can shed any light on why this happened!


You aren’t still on are you? This exact same thing happened when I tried to pair a couple Hue plugs that happened to coincide with my hub (briefly) being on .123. I ended up putting them on a Hue bridge until the HE firmware was sorted. I paired them to HE today (on and they paired up just fine.

No, I'd rolled it back and was running on .121 this morning/yesterday when I was trying to add it again and have since updated to .124 this afternoon :slight_smile:

Did you use the Hubitat Diagnostic Tool to do this rollback? It's different from the "regular" hub (database) backups that you can capture, download, and restore from the admin UI--those don't include the hub firmware. If not, you just restored your database/settings to an earlier time but were still on .123, and that could have caused the problems mentioned above.

But if so...then ignore me. :smiley:

I did exactly that (still being a novice) just using a local restore from a backup, I did see afterwards there was the ability to back down the firmware through the diagnstics menu but then there was a distributed platform rollback which I took advantage of :slight_smile:

The platform was running ok, this was more about the buttons not exiting out of dicovery mode

Well then, thanks for sharing :blush:. Let us know if these V2 buttons are better at staying connected than the previous version. You’ll know, because they will keep working. Most of my Hue dimmers are back on the Hue bridge. They disconnect from it too, but reconnect fairly smoothly without any user intervention.
Recently I started adding Lutron aurora rotary dimmers which have a very high WAF rating. I have them spread out among 2 HE hubs and 2 Hue bridges and they are solid so far.


I have a V1 Hue dimmer connected directly to hubitat and it has never disconnected in at least a year since I installed it.

Thankyou @EVOLVING.HOME the battery swap did the trick for me after 3 previous failed attempts.

Same symptoms but I was already running .124 as I checked for an update after reading your post.

1 Like

Wow, you taking the effort to post this solution saved my day! What a strange solution but very effective! :+1: :smile:

1 Like