Peanut plug and GE Zigbee switch 45857 won't connect with zigbee channel above 20

Just creating this topic incase someone else is having issue trying to connect these 2 devices. No issue with channel 20 and below but I could not connect them above 20.

Securifi peanut smart plug
GE/Jascon zigbee switch 45857


I know it's been a while but thank you! Worked for me. Now having trouble with Zigbee disconnects. Moved my peanut plug a little closer to my hub. My other device is a 2015 era ST Motion sensor.

1 Like

What worked? /i have a couple of these peanut plugs that I can't get connected. Should they be able to connect? They were working with ST.

change your zigbee channel to 20 or lower.

ah crap. thanks. What's that going to do to all my other zigbee devices?

So for some of them I had to put them in pairing mode then go into "Discover zigbee zwave devices". Nothing came up because they were already paired but the devices started working again. Otherwise I think the zigbee stuff may catch up eventually.

Just another FYI on my experience with joining 2 brand new Peanuts to HE. They wouldn't play nice on my existing Zigbee channel 12 (Not discovered). Changed to channel 18 and still no dice. Channel 20 was the magic number for my case. All existing Zigbee devices are finding their way home QUICKLY on the new channel 20 as well, with no manual re-pairing necessary. Thank Yoooouuu BABY JESUS!!!

1 Like

Channel 16 wouldn't find them, but channel 20 worked immediately. Maybe, if I get really bored, I'll test some other channels.

Well, why not test all the channels if you are bored :grin:.
Channel 18 and 19 are working as well.

Adding to this post for my own future edification...

I have to keep my Zigbee on Ch 18 or lower to support 2 first gen SmartThings motion sensors I have. I now have 4 Peanut plugs - I HAVE to be on Ch 20 to get Peanuts to join my mesh, then I can revert to Ch 18 and everything (including the Peanut plugs) works fine.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.