PC Controller not showing all devices (Z-Wave)

I'm using a Silicon Labs Z-Stick and PC Controller; I have successfully removed several ghost devices.

My issue now is that I have three devices, numbered 52, 53, and 54 (one is a ghosted controller), but PC Controller shows only devices numbered up to 45, plus the current controller at 51.

Am I missing something? Thanks.

OK, it took multiple tries to get the controller to exclude, but after that I reincluded it and the additional devices appeared.

Exactly - when new devices are added to the hub, they donโ€™t automatically make their way to the secondary (PC) controller.

1 Like

True, and the secondary controller must ask the primary for the list. In PC Controller, near the end of the Controller Menu, there's a button labeled Update. That is what makes the request. Unfortunately, if the difference is large or the time since last update is large, it doesn't work and I found I had to exclude and then include the secondary again.

5 Likes

suck same issue.. not updating device list... luckily the device i needed to exclude which was a battery device and dead so i could not force a refresh and failure in hubitat was there and i was able to remove it.. but since i have stick plugged in i want to update the device list..

what is the option for removing a dead zwave battery device in hubitat witout leaving a ghost.. there doesnt seem to be a way>

@bobbyD

It sucks that I run into a "does nothing" update so often. It seems to go through the motions of getting an update from the primary. But eventually I cave in and do another Include of the Secondary.

ya i couldnt get it to re-pair/include as well. tried like 10 times.. finally did a couple of extranous excludes for no good reason then got it to pair again and pull in the refreshed list.

I know people say to exclude it when done.. but i just disable the device in hubitat and have not had any issues.

Use Remove button on Z-Wave Detals page, never force remove a Z-Wave device from Devices page, as that may only get rid of the driver, effectively creating a ghost.

that is the issue no remove button.. just refresh and since it is a battery device remove never seems to show up.. is that a bug.

i was under the impression that is the way battery devices work..

and there is no choice to force remove the device on a dead battery zwave device as exclude if i am correct is not operable.. thus only option is a zwave stick?

Not a bug it's a "feature". You can't remove a node that isn't marked as failed by the radio. Unfortunately, we have no control over what gets marked as failed and stays in failed table in order for us to show the remove button. Refresh, reboot, and generally patience, would eventually force the radio to mark it failed so you can remove it.

no it was non functional for over a month.. that is why i replaced it.. new batteries didnt help dead.. and it never got marked as failed.. sigh..

i have become not a big fan of zwave devices for this issue.