Pairing Yale Conexis L1


#1

I'm trying to get my Yale Conexis L1 to pair with my Hubitat. I know it's not on the supported devices list but all I want is the basic Generic Z-Wave Lock functionality so I thought it was worth a try. I'm getting half way there I think. When I try to pair the lock to Hubitat the discovery process does find it. The lock gives me the cheerful confirmation beeps to confirm pairing but Hubitat just sits there at "initializing" for a few minutes and then gives up. I've tried this with the hub 1m away from the lock to see if it helps but it doesn't make any difference.

Is there any way to get more detailed log information about the pairing process out of the hub? Or is it possible to "force" the hub to pair, I've tried manually adding the Generic Z-Wave Lock device with the Z-Wave device ID that Hubitat assigns when it initially sees it during discovery but it doesn' t work. I guess because Hubitat isn't see the pairing as complete?

Has anybody succeeded in a similar situation?


#2

I had some issues pairing a YRD226, wasn't till the fourth attempt that it finally paired. They can be a little temperamental. I did end up factory resetting the z-wave module on another one to get it to pair. In my experience they are hit and miss, just don't give up... Let that lock know who's the boss!


#3

I have 2 of the YRD226 locks and one paired first go and worked perfectly but the other just didn't want to after multiple appempts even from 6" away. I ended up putting a zigbee module in it after the last update and it paired from the other side of the house first go and works great now.


#4

Thanks @Christopher, @tlrfreak. Appreciate the advice. I'll have another go at some point, as I get nearer a full migration away from ST :wink:


#5

I've tried many times, even with the hub 5cm away from the lock. Same behaviour every time, lock confirms but the hub doesn't finish pairing. I also tried joining my ST hub to the hubitat z wave network and then pairing via that. When I do that the ST app tells me that the lock didn't successfully exchange security keys. I'm using the latest 2nd version of the Yale Z-Wave module in the lock. @mike.maxwell Is it possible that the Yale Z-Wave module is using a key exchange that isn't yet supported in Hubitat? (I've now re-paired it with the ST hub without any issues)


#6

I've tried numerous times adding the Conexis L1 but it just will not connect. This is what happens:

  1. Set Hubitat to discover
  2. Set Conexis to inclusion mode (press R button 3 times)
  3. Hubitat discovers 'Z-Wave Device nn' and says 'Initializing'
  4. Yale makes a timeout sound a number of seconds later
  5. Hubitat stays with the device 'Z-Wave Device nn'

The 'Z-Wave Device nn' has to be excluded, by going into the Hubitat settings and using the exclusion, which I see in the logs it works. But, the Yale can then no longer be included without resetting the z-wave to factory, which you can see how to do in this manual.

Not always, but sometimes you can then start the process again. Mostly it's trial and error of factory resets on the device and excluding from the Hubitat.

I'm slightly concerned this Yale lock will never get added as it's primarily a UK (possibly European) only device due to the deadlocks we use over here. There aren't any other smart locks that do this in the UK since Yale stopped selling their old deadlock locks. I could be wrong, and hoping I am.


#7

Hey Hubitat staff, do you guys have an idea of what the problem might be? Are there any plans to resolve? I'd be gutted if I had to keep the SmartThings Hub running just for my front door lock.


#8

Hi @mike.maxwell @bravenel could you let us know if there are any plans or intention to look at this pairing issue with the Yale Conexis? It's about the only option for uPVC doors here in the UK. If not I guess I'll have to keep my ST hub as part of the system just for my lock, but that would be a shame. :cry:


#9

We recently identified an issue with a new lock that would not pair, the symptoms sound similar to what you describe. In the case of this specific device it was not following the Zwave spec regarding certain informational commands that are supposed to be available irrespective of the secure pairing status, since the request for this data was being done prior to security establishment, the request for this data was being ignored by the device, causing the pairing process to try again until it eventually gives up and the pairing would not complete.
Switching a few bits around in the secure pairing process fixed this issue, though it wasn't our fault in the first place.
That code change is being tested right now, it should be in the next release, I can't say if it will resolve the issue with this device or not.


#10

Thanks Mike. Appreciate the detail, sounds possible this will work for the Conexis too. :crossed_fingers:


#11

Very much apprecited Mike. Will test it as soon as it's released and let everyone know how I get on.


#12

Hi @mike.maxwell, was the above code change in testing part of 1.1.6 by any chance? I'm presuming not given there was only 2 days between your message and the release.


#13

correct, that code is not in 1.1.6


#14

Is the fix in 1.1.7? I can't see anything in the release notes that specifically mentions it.


#15

It's in 1.1.7 not all super technical details make the notes


#16

Ah, that's disappointing. I just tried pairing the lock again after updating the hub and I got exactly the same behaviour as before.


#17

As a Conexis customer, is there any information I can ask Yale for that might help understand why the HE hub can't complete pairing?


#18

Is it worth trying to pair the lock again after the new 1.1.7.119 hotfix? Has anything been changed that could fix the pairing process?


#19

Unfortunatly no.
When it stops in discovery after getting the id If you then go to the zwave details page, is the lock shown in there with a discover button?


#20

Nope, the lock isn't shown in the list of z wave devices at all. I tried pairing again and looked at the z wave info page a few times during trying to pair and also after the hub gave up on initializing but it didn't appear.

What's weird is that the lock makes the "pairing successful" noise even though HE remains stuck on initializing. If i then put the hub into exclusion mode and perform an exclusion on the lock, it makes the exclusion successful noise as well.

I've seen other posts mention a z wave debugging mode. Is that something that could give us more info whilst trying to pair?