Odd behavior tonight - HE out of sync with devices

Evening all,

I have only a handfull of devices so far but have some simplistic rules that turn outside lights on/off with the sunrise/sunset.

Not until I was about to take the garbage out, did I notice the back lights were off (the pitch black was my giveaway). So I run to the front of the house to see if the breaker had tripped and confirm the light in the front was on. It was.

so I loaded my dashboard up and when I clicked the tile, the icon turned to the "waiting" icon and took no action. I ended up physically checking the switch and turning the lights on from there. Then as I was going to call it a night, noticed the front light was now out.

In the screenshot, the 2 tiles I have circled in red, the lights are ON, but the hub believes otherwise.

What is the recommended course of action here?

In addition! the 2nd row "Lamp" shows as being off, I can click to turn it on (oh it's already on), then click again to turn it off... the lamp remains on! expecting to physically turn off the smart plug at the plug.

Are these zigbee or zwave devices? And what are the distances to the hub? Reading your description it seems to me the devices are out of range or the radio network that they are on is either busy or not relaying the commands correctly.

Here are some options you could try (and check the logs whats happening then)


Zwave Cleanup

Zwave Repair



Zigbee Status

Is this a new install? What brand/model switches are these? Are they z-wave or z-wave plus? If z-wave they won't reflect status with being polled and you will have to install the built in z-wave poller. Can you also post a copy of your z-wave details page in it's entirety? (Screen shot it)


Thanks everyone, no not new. This has been running flawlessly for months now.

The 3 devices are all actually WiFi, some of my devices I've had BEFORE my Hubitat was here.

Ironically they are all Kasa devices

1 Kasa wall switch - "Front door outside light"
1 Kasa outdoor plug - "Backyard Lights"
1 Kasa indoor plug - "Lamp"

The Front door outside light and Backyard lights are controlled based on sunrise/sunset. I woke this morning and "Front door outside light" is off, but "Backyard lights" is still on. But the device tells me the command was called at sunrise.

So this 1 device this morning is out of sync, so where should I normally take something like this?

Kasa devices don’t report status back to the hub, they have to be polled. On each device page you can specify how often to poll them (the less frequent the better). This shouldn’t be an issue unless you control them outside of Hubitat. In my experience, Kasa devices need a really good wifi signal or they can be problematic. So either the wifi has changed (since they were fine), there is interference from neighbors or new devices, or you’re using something else to control them (Kasa app or a voice assistant).

Good to know then, I am working towards more zigbee / z-wave connections (all zigbee so far). I will work more towards diagnosing this device. I've realized it's not even communicating with it's own Kaza App (I don't tend to even open).


1 Like

full transparency update... it's the Kasa Wifi devices, they have remapped in some cases, so that is why it wasn't working. I have removed ALL devices and attempting to reintroduce but naturally even that's not working so well.

The couple Kasa devices I use I have assigned/reserved their IP addresses on the router and disabled cloud control for the devices. They should work fine that way as long as they have a good connection.

A few days ago I had a power failure and find out I need a UPS for HE to avoid caos. Right now I have Kasa Wifi devices (5) and they stop interacting. Can you please detail how to solve the problem?. I am new to HE. I tried assigning an Ip to some Kasa devices but keep messing up. I think they are still being controlled by the Kasa App, do I need to remove them from the App? Thank you

Hey there, I can confirm I recently had a power outage too, but don't recall any issues with my Kasa devices. Being listed in the Kasa app shouldn't affect being paired with HE. When you say you've added IPs but keep messing up, what does that mean to you?

I am new to HE too so I'm still learning how to make things work. Every time there is a power failure (I live outside of US) all Kasa devices stop property working (Waiting for the battery backup for HE to avoid that problem). I read about assigning on DHCP router a fix IP for Kasa devices, so I logged in into my router and assign using MAC Address of each device a fix IP for 2 or 3 devices to test and removed those devices from Kasa App . Don't know what I missed but could not establish communication with any devices, so decided to go back assign them to cloud control and start the configuration from scratch. Everything is working well, but I will like to keep using the Kasa Devices and disable cloud control. I should be missing something to disable cloud control

Open the Kasa app and click on a device. Then tap the gear icon at the top right to open the device's settings. Toggle remote control off. Do that for each device and cloud control will be disabled.

Opened the Kasa App, clicked on the device and got to this screen that does not show the option Remote control Off. Here is a copy of the screen

On devices info I get MAC Address etc but no option of remote control ON/OFF.

The app must be different in the U.S. I think there is also an option in the Hubitat driver to disable Kasa Cloud control. I moved the Kasa outlets I had off of the Hubitat hub for the transition to the C-8 hub (just in case), but remember there being a way to do this in a Hubitat driver. Check on the device page in Hubitat and let me know if it's there. Otherwise there is another way, just more involved.

Does it works only on C-8? I have C-7
Thanks for your feedback

It works on C-7

Great. I will look for the option to turn off remote control on the app
Thank you

1 Like

Hey everyone, jumping on here again, my lamp was not turned on, well technically I noticed it was on one evening in the middle of the night too, but that's not important now.

After confirming the correct state of the plug, it was responsive through the Kasa App. I only needed to reserve the IP address on my router again. naturally forgot I had to reset that recently.

My router, it's Advanced / Setup / LAN Setup

you can specify devices to maintain a specific IP address. So in my case, my C7 HE was looking at, but my device was now living on Once I reserved the IP, the lamp was FULLY responsive from my dashboard again.

Hopefully, this helps.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.