Not triggering leak sensor rules

This is the first time I have seen HSM not send out an alert that one of my leak sensors detected water. This morning there was water around my furnace due to the humidifier and the Dome Leak sensor was in the water. Looking at the logs the sensor did fire:

None of the rules in HSM fired off to alert:

And when looking at the logs you can see the trigger event:

Is ther a bug in HSM for this not working in: 2.3.3.140? This has always worked in the past and if I wouldn't have gone into the basement this morning I wouldn't have been alerted to the leak. I have tested every leak sensor in the home and none will trigger HSM actions.

Suspect @bravenel will want to also see the status page for HSM.

Which status page would that be? The only ones I know of it the app page and the HSM page for the dashboard.

Also there seems to be a bug, I setup a "custom" rule and added my test lead sensor there and set up a couple of alerts. I armed it and bam it worked. Then when I disarmed and re-armed HSM the custom doesn't arm even though the arm button said "Water and Custom". I will wait to hear back from the folks at Hubitat.

image

The cogwheel for the HSM app page - it will show all of the subscriptions, etc.

Well I tried a couple of things and finally got HSM water to work again. I had to remove all sensors from the water section I left the actions in place. Saved HSM. Then went and re-added the sensors and saved HSM again. Tested and everything started to work again. I didn't find any delta's on the configuration page (cog) from a device perspective. So go figure.

Download the Hubitat app