Not activating Philips Hue bulbs on Alarm


#1

I've currently setup my HE HSM with Intrusion-Home and Intrusion-Away with the Lights Alerts to use my Philips Hue bulbs. I've tried selecting the bulbs, or the Groups, using the Set, or Flash options. However when tripped, they are not using the lights - just my siren goes off and I get my Text Alerts and Notifications. The HE can control the lights by the Dashboard no problems. Is there something I can easily modify to make this work? I'm new to using the HE and home automation.


#2

Hello and welcome to Hubitat!!

First, Hue bulbs don't support the Flash command. So that won't work at all.

And what types of Hue lights are you trying to control within HSM? Are you inputting a level after you select the Hue lights?

Also, the lights will only come on when there is a full intrusion. Not during an intrusion delay. Just FYI.

If you could post a screenshot of your HSM setup, that would be helpful.


#3

Welcome to the Hubitat Community! As @Ryan780mentioned, Hue don’t natively support flash. You can do a slow flash by creating a rule to turn them on and off, and then triggering that rule via a virtual switch. You also need to create a stop action or they’ll keep flashing.


#4

This driver below supports flash commands, haven't tried it yet though.


#5

I just tried this and it seems to not be able to be used if you have a Hue hub also. So, it looks like a one or the other thing.


#6

Having the same problem. Not using flash at all. Simply trying to set the bulbs red @ 100% after an intrusion. This was working fine, but hasn't been working for a couple months I think. I've completly rebuilt the HSM rules, but the same issue persists. However, I can set the color using the device function directly, so I've confirmed that the system can set colors. Seems to just be HSM that's having issues.


#7

You can get them 100% red through HSM and Rule machine. I'll post something later tonight.


#8

Sorry for the delay on a reply to this. It is for Philips Hue Ambiance and Color Gen 2 bulbs, 7 of them. I'm hoping Hubitat can patch this soon, I'd like to get the full security system working without having to purchase more equipment.


#9

Sorry for not following up....this is actually pretty simple from within HSM.

Just go into "Light Alerts" and then select your bulbs and then set the color and level.
image

Are these directly connected to your HE? Or are they connected to a Hue Bridge. These bulb are not very good repeaters for other Zigbee messages for ZHA protocol devices so you will have problems with dropped messages from ZHA devices with these on your primary HE zigbee mesh. They are best kept on a Hue bridge or a dedicated HE hub.