Not a big step forward, error on first attempt

Just playing around with the new EZ Dashboard in hopes of building a dashboard for my home that has a nice GUI on my iPhone.

I find the entire process circa 1990's and well out of step with other platforms. A lot of in the weeds details to accomplish the most minimal of results. I fail to understand many of the accolades for this.

Anyway I created a start page for my dashboard which is nothing more than five 1x2 text tiles which will be used to jump to secondary dashboards with devices on them. When I try to load the dashboard via the hubitat app on my iphone I get the ever so helpful error message

{"error":true, "type" : "AppException" , "message":"Not Found"}

The dashboard is fully viewable from a PC web page via Hubitat Remote Login but creates errors when attempting viewing via iphone.

Any suggestions?

Did you create it on your phone first or on your pc first?


hmm... What happens if you try to create on ios first? (it shouldn't matter, just trying to break down where your issue is)

I deleted easy dashboard thinking I'll carry on with the old dashboard for the time being. Most of the youtube help is on the old one anyway.

So I have dashboards still showing up as ez dashboards even with that app removed. I thought I'd copy an dashboard over to see if it can be converted to a non Ez dashboard and I get this error.

..."Copy Device information from Kitchen to a new Easy Dashboard now?"... 

I don;t understand why EAs Dashboard is still referenced when I unloaded that app.

Can you clarify what you mean by this. I think Easy Dashboards are just part of the regular Dashboards app so I am not sure what you are trying to say. Did you just remove the Easy Dashboard instance of a dashboard.

1 Like

In case you missed it, there is a 2 weeks old video that covers the basics of using the Easy Dashboard. As always, please feel free to share your struggles in more details so we can improve the experience for others who may run into the same problems you had to deal with:


Yes I saw that video.

Here are three screen shots showing a number of experimental dashboards I have created. I created most of them as legacy dashboards (at least I meant to). Yet in some locations they are labelled EZ dashboards and others not as EZ dashboard. Lastly all of the EZ dashboards when opened via the iPhone app give the previously mentioned error message in my first post of this thread.

So I have been trying to revert back to legacy dashboards but I seem to be locked into EZ dashboards and they won;t load in my iphone. Legacy dashboards will open in my iphone.

lastly is the error screen I get when I open an EZ dashboard from the hubitat iphone app.

The ez dash's may not show up in the original app. They work fine in the current app which is in the final beta stages and due to be released soon.

They show in the non-beta and beta apps.

1 Like

They don't show for me properly on the original app on my ipad, but show fine it the beta app on both my phone and ipad..I removed the original app on my iphone so I can't attest to that part. I don't do much in the way of dashboards to be honest.

1 Like

This is not the expected experience and I haven't seen other similar reports. I would like to get to the bottom of your problems. It sounds like you are doing everything that is expected, which is go to Dashboards, select the type of dashboard you'd like to create and follow the steps specific to each dashboard. If you select Easy Dashboard, then you have to add devices, click save and you're done. In the case of Hubitat Dashboard things are a little more complicated as you have to authorize devices in the Dashboard app, then come back to Dashboards page to create the dashboard using appropriate template. When you get a chance, please send me your hub id in a private message so we can further investigate.

Yes, local dashboards are broken for me in the regular non-beta app. They seem to be hit or miss depending on the version of the beta app. The last version they broke. The latest version they seem to be working. However, my point above is that EZ dashboards do show in both apps and β€œshould” work in both.

1 Like

Please keep us posted if they break again. "Hit or miss" is not what we want to hear, so we would like to know if it happens after updating both the new Mobile app and hub to latest versions.

I’ve been letting @gopher.ny know in another thread and message. For lack of a better expression, local dashboards have been a β€œhot mess”for me with the last few builds (beta and non-beta), They are completely non-functional on the non-beta app. I was told to use the beta app, but they flip-flop as to working or not depending on the version.

1 Like

The good news is that both new beta apps are on the final versions before they are publicly released, so if everything goes well with both, that will be the last update.

For iOS is build 272 and for Android is build 234. Please let us know if your experience is still spotty.

A post was split to a new topic: Easy Dasboards navigation issue on iOS Mobile app

My iPhone Hubitat app is Version 1.3.2 and Build 163. That seems well out of date to the 272 mentioned earlier. I only have the stock App store version but it is as up to date as available.

Maybe I have the wrong iOS app? Is there a newer or different Hubitat iOS app? Maybe some of my issues are simply the wrong client app in my phone?

272 is a beta version. You have to sign up for it and then receive it through apple test flight.

I'm having the same error message after migrating to a C7 from a C5. Thought it was with my migration but after deleting and re-creating the dashboard, still no access with iOS. I guess I have to wait for the next app release to be able to use my dashboard?