"No response" using new HomeKit integration (beta)

I did the update, added the app and exposed one device to HomeKit and while I was able to add the bridge fine, when the device came over, the '*** controller' device shows 'No Response'. The button device doesn't show this, but then, I'm not sure it would? I've force quit the Home app and re-launched, no difference - it shows "Updating..." for a bit and then goes to "This accessory is not responding." - other 105 HomeKit accessories (some native, many through HomeBridge - subset of them through MakerAPI, and some through scrypted) are all responding fine, so I doubt this is an issue on my network.

Rebooting the HE doesn't help, either.

No logs of interest, either ... I don't see an option in the app to enable more debugging logs, but I may have missed it.

Edit: using the Discovery app to view mDNS broadcasts, I do see the Hubitat bridge (Hubitat Main, in my case) - so it appears that it is visible on the network.

image

hubitat-lan.local resolves (can ping from MBP) and nmap shows the port (60000) is open as well.

Edit 2: trying to add additional info as I think of it - I have 5 eligible HomeKit hubs on the network, 3x Apple TV and 2x HomePod mini. Currently a HomePod mini is the connected hub. I mention this as I believe as of sometime in iOS 15.x all HomeKit communication to bridged devices got routed through the hub, instead of device->bridge direct. e.g. previously, my Home app would connect directly to the Lutron Caseta hub or to the Homebridge device, but since then, it has to hop the connection through whichever hub is connected, so Home app on iPhone -> HomePod mini -> Lutron Caseta.

It is a button controller? I think there's a bug in implementation, which I'm trying to track down right now.

1 Like

im actually having the same issue. I have 13 devices (all types, lights, dimmers, switches, motion sensors, buttons) added. The bridge came through fine in Apple home and it had me identify each device but now they all show "No response" even after multiple hubitat hub responses and even tried switching which appletv/homepod was the main "bridge"...

2 Likes

Same issue. Tried with just zigbee plug, just a button, just a virtual switch. Always no response. Removed integration, rebooted, tried again, rebooted Apple hubs, always the same. No response. Looking forward to this integration! Thanks for doing it.

2 Likes

Uncheck any buttons in the integration

It's a switch, Zooz ZEN71 Switch, per what's listed in my Devices on the hub.

Could you expand on this? Not sure what you're referring to?

Anything that is a button/button controller. Uncheck this within the Homekit integration (beta). If you're unsure what's being reported at the bottom turn on "Show accessory classes and characteristics" and you will see what devices are reporting as...

In the case below I don't want any of these checked. Once cleared HomeKit showed responding to everything else.

Gotcha, OK - I think I see how this is organized - I missed it the first few looks. @gopher.ny - it is listed in the "button" section, as it is a switch, so I didn't respond correctly to you the first time.

So, @rlithgow1 - you're saying that HomeKit devices that are not buttons should all work? I'll give that a shot.

Yeah seems to be a bug in the implementation. @gopher.ny is looking into it. Given it's a holiday weekend it's gonna be a bit. These poor guys need a break :joy:

1 Like

Wait, so you're saying anything with a button characteristic, not just things listed as buttons. Yikes - so, that's like ... 90% of my HE devices, I think ... :grimacing:

So - trying something that doesn't have a button characteristic, a Zigbee window shade (Window Shade, Dimmer, Switch) - and I can't seem to find it? How long does it take for a new device to be exposed in HomeKit? It's been ... 5 minutes?

Totally understand - it's a beta, there's gonna be bugs :slight_smile:

Only stuff marked buttons. Switches and dimmers are fine. Picos and anything listed as a button

Right, I think we're saying the same thing - e.g. in this set, the Kitchen Main Lights and Master BR LED Lights would not work because they have a Button characteristic, right?

OK - I removed the bridge, reset the pairing code, and re-added it, with only the Window shade enabled - and this is still showing as No Response @gopher.ny and @rlithgow1 :frowning:

Once enabled, it should appear in ~15 seconds.

As long as they are not exported to HomeKit as buttons, it should not matter.

Can you PM me your hub's id? I can take a look at the engineering logs on the hub.

OK, well, that's not working, unfortunately.

Gotcha, so if I pick one of the other things (because otherwise it defaults to exporting it as all of those things, I think?) it should work. I can try that, but still, the Window Shades don't work ...

Done

I assume this should also apply to disabling a device and it disappearing? I don't see that, either.

At the bottom of the integration click Show characteristics and you can see what the device is being exported as. If button is there, export as switch instead

I am showing “No Response” too with my devices (Dimmer, Fan, Motion Sensor, Outlet, and Switch). I did not install any device that was listed as a “button” into HomeKit.

Download the Hubitat app