[No longer maintained] Rheem EcoNet Integration

That's not accurate. At least not for the way this integration works. The integration basically mimics the mobile app. I just tested, it's working fine for me. Are you still getting errors? I get them occasionally but not frequently.

Mine is currently working also. Just a few minutes ago I switched modes using Hubitat.

Did it ever work, or is this something new?

I previously used @brianspranger's integration which worked great for the last year, up until maybe mid-April. I decided to give this a try, still no go. Rheem app for Android does work.

Here are a few threads that gave me suspicions about API, but it sounds like your integration may be different.

Clicking refresh shows "Refreshing data ..." in the log, but it doesn't refresh in the device page. Here's what I see in the log when I send any command (API Put Error):

What country are you in? Maybe they have different urls depending on where you are or somethjng

U.S. Someone in the other thread said they called Rheem who fixed something -- I'll dig into that, I don't think there's anything wrong with your integration.

Just one thought in the app could you try re-logging in? Just want to make sure the token didn't get screwed up. I'm US too so that's not it, I was just hoping maybe they had a different url for Europe or something like that...

I'm not having any problems on my end at this time - also located in the US.

Now I AM having problems, looking at the app it appears that they may have redesigned parts of the API. Is it still working for anyone else? I probably need to go back and redo this :frowning:

A little bit of information. I've started trying to dissect this. It looks like Rheem completely changed who their backend provider was. Before the integration was based on a nice, easy to reverse engineer, REST API. Now it is MQTT based. The Android APK is completely obfuscated. Not saying this is going to be impossible, but this is going to be a complete rewrite and a lot of work, so it's not going to happen quickly.

I also need to add a caveat. Hubitat does NOT support TLS over MQTT. This means the only way I can build this is by not using TLS. The username/password will be encrypted because the login method is HTTPS, but the actual MQTT messages will include a token that could be sniffed, reused, and gain someone access to your water heater as there is no way for me to encrypt that information in the current HE platform. Just want everyone aware!

Looks like some HA people are on a Discord channel. Not sure how much progress has been made.

Weird. Mine was giving an error the other day, but I logged back in, and it seems to have gone away. I used it a couple times today, and it seems like it is working.

What about using https://econetreg.myrheem.com/ as a source of data? Not sure that is possible, but thought you might not be aware of it.

Thanks! Looks like they discovered the MQTT topics which will make life a LOT easier.
That said, I haven't yet done any MQTT coding in HE so it will take some experimentation.

Prior to you finding that I already got login and pulling the list of devices working so now I just need to get state and update it.

As long as the Clearblade server truly does support an unencrypted port (their documentation says they do) I think I can get this working by the weekend, but it is a complete rewrite.

1 Like

Confirmed, unencrypted works (maybe cough @chuck.schwer cough will give us encrypted MQTT at some point :wink: ) but in the meantime I think I can make this happen. As a note, the IDs of the devices and everything is different now. So upgrading will kind of be deleting the child device and going through the whole setup process again. The good news, since this is MQTT, no more polling and delay. When something changes on the heater you should get an update pretty much immediately!

I'm making good progress here. I have it where you can set/read the setpoint, and set/read the mode, as well as read the running state. I have one bug I'm working on where sometimes when you change the mode it doesn't tell you it succeeded even though it did. I think it's something I'm missing with the MQTT stuff. Working on it.

Other than that, there are a few things that I'm not sure Rheem supports anymore. You used to be able to read the ambient temperature of the room and the actual temperature of the water (not the setpoint). So far from what I can tell the new API doesn't report these things. I'll keep digging, but right now it looks like they may have removed that :frowning: on the plus side though, the API no longer needs to poll. When something like the mode or temperature changes you receive the update in real-time via MQTT.

@amdbuilder I will likely need your help testing out your gas water heater again when I'm ready since I don't have one to test with.

1 Like

Anyone interested in testing the code is at GitHub - dcmeglio/hubitat-rheem at mqtt_api

My recommendation is that you install this as a new app/driver. The existing device won't match up because they changed all the device IDs. Right now I have a bunch of stuff being dumped into the logs to help troubleshoot issues. Right now I've only tested with heat pump water heaters and only with a single water heater, not multiple.

Does econetreg work for you? I just get this:

I do get that message, and have for a year or so now. But it still let me log in.

Ok, unfortunately it doesn't look like there is any data posted there so I think the MQTT is the only option.


OK, So i just had my Rheem Econet Water heater installed. I have successfully connected it to wifi and to the app. all seems fine. When i try to pair it with Hubitat using your App and driver using my userid and password the message I get from the app is "No water heaters were found."

Do I need to wait for some period of time before Rheem EcoNet registers the water heater? Do I need to manually add the device? I tried that with no success. What am I doing wrong?


Were you using the code I just mentioned in a post a few hours ago? Or the original code? Unfortunately Rheem just redid all of their APIs and broke everything.