New “Round” Sonoff Button Controller SNZB-01P Not Triggering

Just received the latest Sonoff Zigbee button controller from Amazon. This is the new round model (not square)- model SNZB-01P. The device connects just fine with HE. However, the physical button does not trigger the assigned outlet. Checked battery, tried different device drivers, cleaned the state variables, etc but no luck. Curious if the existing Sonoff button controller device driver is incompatible with this new model button or ?? Flummoxed! Any counsel?

Is the driver actually generating events for button pushes? Leave any apps (automations, including rules, etc.) out of the picture for the moment, since it's another layer between what you're really after. Go to the device detail page and check "Events" to see what has been generated. (If you leave descriptionText logging on for the device as it is by default, you should also see this in Logs in real time, but Events is the authoritative source.)

If not, try hitting the "Configure" command once or twice to run it (if it's available with this driver), otherwise consider resetting and re-pairing the device in place without removing it from the hub first (neat Zigbee trick and may help if it didn't get the right driver selected the first time around and Configure doesn't work).

Otherwise, I'm not sure if anyone has really tried this, but the above is your best bet if it should work (which, again, I don't know).

2 Likes

Thanks for the prompt response.

The button device will show “digital” events when the button is pushed using the HE app i.e. the app works fine. The button does not work and does not record an event when pushed physically. I tried the things you suggested with no luck. Tried with two different buttons and both have the same “no physical response” problem. Weird. I have many devices running on my system, many webCoRE pistons running with no issues until I attempted to simply integrate these new buttons. Never had unresolvable issues before.

One note is the new button devices do join HE as a “device.” I then go in and change the device handler to a Sonoff Zigbee button controller. But that is not unusual in many cases. I remain suspect of the device handler. Also, of note- my older Sonoff buttons work fine (the square ones).

Please post the new device details (model and manufacturer), as shown on HE device web page.

@jdgkeg this is obligatory for Sonoff buttons - after changing the driver, always pair the device again to the hub, without removing it.

If for any reason the stock Sonoff button driver doesn't work, you can try alternatively this custom driver,

1 Like

I'll echo the re-pair in place advice. I'll also defer to the two more-knowledgeable people ahead of me, but I will note that I had the same issue, and once I got it working, it has been rock solid since.

This is what I wrote in a different topic:

Here are the Sonoff button device details:

  • endpointId: 01
  • application: 00
  • inClusters: 0000,0001,0003,0020,FC57
  • manufacturer: eWeLink
  • model: SNZB-01P
  • outClusters: 0003,0006,0019
  • softwareBuild: 2.2.0

Tried the Tuyu driver and it works "digitally" but still not physically with a button press. Also, I've tried re-pairing with no luck. Strange as it seems from the other member that they got there's working. Hum...

1 Like

Update...I tried the recommended re-pairing multiple times in a row and it finally started working! Who knows why that is??? Thanks for your help and suggestions. If anyone knows the root cause, please explain for other members to glean.

Are yours staying connected? I have 1 that paired fine a couple of weeks back but I can't get my 2 new ones to stay paired. They pair initially and the button works but then disconnects. Are you using a C-8 hub?

Still connected this morning but will see if that remains the case given more time. I have the c-7.

1 Like

How many times did you pair it before it worked, tried over 10 times now, without deleting

Took about four consecutive tries. Good luck!!

Just received my first one of these today.

Paired first try on my C8. Paired as "device" selected the Hubitat "Sonoff Zigbee Button Controller" driver, and then as @kkossev suggests, I re-paired the device without removing. This seemed necessary, as before the re-pair, it wasn't logging event messages to the log.

Tested, click, double click, and held. All three worked fine.

Added a button controller rule, and selected an outlet to toggle. Works.

Nice, hefty button, magnetic back, 2477 battery. About 10% bigger than a Samsung button, much more refined looking than the previous generation Sonoff SNZB-01 buttons.

It came with a nice mounting plate and screw, although the plate is powdercoated an obnoxious orange color.

All in all, a nice button. Will observe to see if it stays on the network.

S.

1 Like