New Hubitat, No Hub Light

I just got a new Hub, and when I plug it into my router and power, the light doesn't come on.

My router says that it had connected at some point, but isn't currently and I can't connect to it to try any sort of reset from a web browser. I've never connected to it from a computer.

I've entered a warranty case as well.

1 Like

Maybe try a hard reset using the internal button on the hubitat itself?

Also try plugging something else into the same outlet to ensure the outlet is working properly.

Thanks! Confident the outlet is fine (and I've tried plugging it in an alternate outlet as well) and it didn't appear that the hard reset did anything either.

That’s a network settings reset button, so if the hub appears to not be receiving power, it’s unlikely to do anything.

Have you tried a different USB C power supply than the one that came with the hub?

1 Like

Yes. No luck there either!

1 Like

I’m sure staff will sort this out for you.


I'm in the same boat it seems. I've sent an email so far and posted in the forum.

FYI - support doesn't respond to emails. Either contact them through the Support Portal, or through the Hubitat community forum.

If your "dead" hub is also a C-8, submit a Warranty Claim here:

If you have an older Hubitat, but with a Hub Protect subscription, you can submit a claim here:


That's not a hard reset button. Holding that for 7 seconds simply resets the network settings.


I've had good communication with the staff; and things are on the way to get sorted soon. Thanks!


Things are sorted and the replacement hub works! I've got other things to figure out, but that's for another day.


Glad you got it sorted. Take a gander at this thread. It will help you avoid some gotchas.

This may or may not help, but I found the C-8 does not work with any of my C-to-C USB power cubes. The Hubitat lights right up using any of multiple A-to-C power blocks.

Odd I guess but no sweat... Have plenty of old OEM phone cubes so I'm up and running now.

Download the Hubitat app