New hub stuck in reboot

Hi there. I bought a used c7 hub. I specifically mention that in case it can be any cause of this. Anyway, through the app I found the device and clicked on register. It went though a firmware upgrade and rebooted. It went through the flashy animation as it started up but then just gets stuck on the rebooting screen, saying "Hub reboot in progress. This should take 2 minutes or less.". Many more than 2 minutes later, as well as some restarts, same thing.
What can I do about this? I'm assuming nothing to do with a used hub since it is detected and upgraded firmware.
Thanks.
Alan

When the hub gets stuck on that page is the LED green? If so the hub UI is up and running but for some reason you can't reach it. If it's some other color there's a different issue.

If it is green can you look at your DHCP table and confirm it grabbed the IP you think it did? Can you get to the diagnostics page on port 8081? I

Thanks for the reply. Light is green and I can get to the diagnostics page.
Should I try rolling back and reupdate or do you have some better advice?
Thanks
Alan

1 Like

Try a soft reset from the diagnostics page first. That will factory reset the hub database. May need to do a Zigbee and zwave reset also once you get into the UI.

Could also try Download Latest Version if that doesn’t work, which I think will reinstall the newest firmware.

2 Likes

In addition to what @jtp10181. Once you do get in and reset the z-wave and zigbee database, on the z-wave details page there should be a z-wave firmware update button. Click that. If it's not there it's already been done. Do this post platform update (settings>>check for updates)

Thanks.
I did a soft reset but still stuck in boot loop. I tried restoring previous version but wants to update when trying to log in again. I'm assuming the zigbee/z-wave resets would not influence and only needed to get up and running once I can log in

Hmmm. Did it have a static ip?

I may be missing something, but these would appear to be in conflict, i.e. if the hub is constantly rebooting you shouldn’t be able to get to the diagnostics page. Might try clearing the browser cache and cookies.

If it runs for a while and then reboots, I’d try a different power supply and cable.

Sorry, boot loop is not the right word, but it is not getting to the normal login screen. If I try connect via IP, it just shows the page that says it's still rebooting. It never leaves that page.

No, DHCP

OK, I can get into the normal menu if I manually enter the address (e.g. Http://[IP]/logs. Operating as normal then. I will check the settings and get back to you

Thanks for the help so far

I reset zigbee and z-wave, rebooted through the menu and it is now operating as it should.

Thanks for all the help as usual.

2 Likes

Don't forget to update your z-wave stack!!

Will do, thanks. I use zigbee so not a concern but possibly a frustration if I move over in the future.

1 Like

@bobbyD I know there was an issue a while back where people would get stuck at the get started page but I have not heard of it getting stuck at the rebooting screen. Is there any fix for this?

@AlanB So you have already tried a soft reset and firmware is updated to current version correct? Should be 2.3.3.140?

Can you post a screenshot of the page it gets stuck on?

1 Like

Jumping from an older version to 2.3.3 may face a database upgrade issue. @AlanB I would follow the steps in this post:

I tried the soft reset and version was correct.
However, once I manually typed in an address and got to a page, it never gave me that problem again. So now works fine.

3 Likes

Going to tailgate here, as I'm having the same issue. New hub, new user so I don't know what to expect. The hub has a dynamic ip. The browser is on xxx.xxx.x.xxx/gettingstarted, stuck on the "Rebooting" page. "Hub reboot in progress. This should take 2 minutes or less."

At one point, during the process it indicated it was upgrading firmware and then loading drivers but stuck after it indicated it was rebooting.

The only thing I can get to is the :8081 diagnostic page. Did a reboot, soft reset, download latest version. All run and then get stuck on the same xxx/gettingstarted page reflecting rebooting. Also tried a hard reboot by pulling power, same result.

What color is the LED?

Click the Hubitat logo per one of the devs.

Just following up on my previous post in case anyone else experiences it. I found that with the mobile Chrome browser I was able to get to other locations such as xxx/logs.

I logged in to the same IP using a desktop browser and got the expected Hubitat page. After doing that,

Download the Hubitat app