New C8 keeps crashing/locking up

Agreed - if this is the case, it's a bug that needs to be addressed.

Anyway, here are the logs from that AP at 3:00AM. If I were to guess, I'd guess that's channel optimization. I'll disable that and hopefully that's a good workaround for now.

I seem to recall someone else was having similar issues with optimization turned on..

1 Like

Just to get back... it seems to have corrected itself with the past few firmare updates. I even decided to, and sucessfully, migrate WebCoRE from user to the internal one. Maybe that also helped.

1 Like

I was having a similar issue…C8 locking up once a day for a few builds. C7 (on the same network) not locking up. Both are connected by Ethernet via unmanaged switch to Eero Pro 6E, but I have also enabled WiFi on the C8.

Symptoms were just an absolute lack of response from the iOS Hubitat app, or via the web page. C8 also shows up in the Eero as no longer active (wired or wireless), Green light is on and solid. Removed power, waited, replaced power….problem temporarily solved.

Rather than using the USB dongle that came with it I was using a wall outlet with a USB port. I opined that maybe the C8 needed more current and was maybe flaky due to limited current (1A). I thought it might be like RPis which work with a 2A power supply and aren’t happy with smaller current producing wall warts. Unfortunately, the Hubitat site had no real documentation on requirements for electrical current.

So, I connected the C8 to a 2A USB power supply, just in case. Still locked up.

Then, after a couple of builds, as the previous poster reported, the problem seemed to go away (build 140 I think)….and yet now it is back (build 141), although the problem seems to occur less frequently. Potentially locks up 1 day of 3. Currently on (I update as soon as new builds come out - there is still a lot of churn for C8 - and the stability seems a little lacking still). I keep C7 an C8 on same build, and have mesh enabled (although I have no devices currently connected to the C7.

(I tend to test the more “iffy” devices out first on the C7 (e.g., cheap Zigbee 3 devices that will pair, but never report anything (can’t find a good driver - any modifications I’ve made to drivers haven’t made an improvement either))). But of course this comment has nothing to do with the locking-up topic, and I don’t have expectations for them to work anyway.

I have reserved IP addresses for both Hubitat devices.

WiFi client steering is on (but based on location - the C8 should never shift (and I’ve always found it attached to the same router device (of 3 I have installed))).

Probably useless information, but I found it odd that when the lockups were daily they occurred sometime around 14:30 local time (based on “last seen” information from the Eero router). But, I couldn’t find any specific scheduled tasks that occurred around that time, and I didn’t see anything anomalous elsewhere on the network.

With the latest build, when the lockup occurred, it was near 17:30 local time…still nothing stands out related to scheduled tasks or events. In neither case are there any mode changes setup anywhere near those times.

So far, it has only occurred once since moving to 141, but I wasn’t seeing this at all in the past.

I also seem to have a lot more stalled loads in the app after picking “Connect to hub” recently. The loading indicator gets to about the end of the left panel, then stalls. Going back out and selecting the other hub, then coming back sometimes goes through clean, but sometimes I have to force close the app.

Not big enough issues to report, but since I was already writing this up, I am adding a couple more observations,

I have been having the same issue with the C8. It seems to go a few days but then locks up.
If I am home I can tell when the lockup occurs. My morning automation's to turn on lights do not run which I just saw this morning.
No response on the main web or the diagnostic port (8081). Green light is on.

I upgraded from a C5 that ran without issues for a few years on the same network setup.
Hub is on a reserved IP with a comcast/Xfinity modem, then Ethernet through a switch to the hub.

Unmanaged switch and wifi is off.

This last lockup occurred last night around 6pm, last log entry is
2023-06-08 06:26:56.021 PMinfoPIN-4 voltage is 119.045 V

Hub has been up about 7 days with
|systemStart|System startup with build:|||2023-06-09 08:43:52.716 AM EDT|
|systemStart|System startup with build:|||2023-06-02 09:45:17.933 PM EDT|

This may be anecdotal, but it seems 1.46 is better than 1.40.
With 1.40 it would lockup every 2-3 days (5/20, 5/22, 5/25).
1.45 was unknown as I updated to 1.46 in a couple days (5/31 to 6/2).

Another crash last night.
Logs stopped 6/14 at 05:18, Rebooted the hub (power off/on) at 6:40 this morning.

dev:102023-06-15 06:48:37.282 AMinfoMotion Inside is inactive
dev:1392023-06-15 06:48:17.756 AMinfoPIN-6 voltage is 119.141 V
dev:1112023-06-15 06:46:53.177 AMinfoPIN-4 voltage is 119.045 V
dev:1122023-06-15 06:45:07.724 AMinfoPIN-5 voltage is 118.897 V
dev:1082023-06-15 06:43:25.458 AMinfoPIN-1 voltage is 121.165 V
dev:1392023-06-15 06:43:17.834 AMinfoPIN-6 voltage is 119.296 V
dev:162023-06-15 06:40:29.447 AMinfoTelnet connection to Lutron interface established
dev:162023-06-15 06:40:28.853 AMinfoLutron Telnet is still online

dev:1392023-06-14 05:18:19.577 PMinfoPIN-6 voltage is 120.236 V
dev:1112023-06-14 05:16:55.228 PMinfoPIN-4 voltage is 120.160 V
dev:1092023-06-14 05:15:29.740 PMinfoPIN-2 voltage is 122.124 V
dev:1122023-06-14 05:15:10.018 PMinfoPIN-5 voltage is 120.000 V
dev:1082023-06-14 05:13:27.984 PMinfoPIN-1 voltage is 121.875 V
dev:1392023-06-14 05:13:19.715 PMinfoPIN-6 voltage is 120.000 V
dev:352023-06-14 05:12:35.725 PMinfoChime Bsmt temperature is 72.2°F
dev:352023-06-14 05:12:35.725 PMinfoChime Bsmt humidity is 54.1%
dev:1392023-06-14 05:08:19.566 PMinfoPIN-6 voltage is 120.394 V


Can you PM me the hub id? I'll take a look at the engineering logs.


I'm having the same problem. Crashes pretty much everyday. Sometimes over night, sometimes during the day. I'm not doing anything fancy, just running a few z-wave devices. It's very frustrating, I'm ready to throw it in the trash.

Ethernet or Wifi connection (or both enabled)?
Can you access the diagnostic port (8081) when the hub goes down?
What color is the LED on the hub when it is down?
Are device / automations still working when it goes down?

1 Like

Ethernet. Wifi wouldn't work when i got it. When it goes down nothing works until I unplug it and plug it back in.

Led is still green when it goes down

Have you specifically tried getting to the diagnostic tool?
If even that does not work it signifies a networking issue that is taking down the ethernet interface. Typically if the hub OS itself crashes the diagnostic tool is still running.

The most common cause for the ethernet to crash is when you have a router/device on your network with Jumbo Frames enabled. Any multicast JF packet that hits the hub has been known to crash it. It is some sort of hardware issue with the ethernet interface used on the hub.


How would I find which device is running jumbo frames? I have verizon home internet and no router.

It would be in the configuration of your ethernet devices that have a gigabit ethernet interface. Depending on how many such devices you have, it can be easy or complex to track down.

But there's another approach to deal with this:

  • Purchase a cheap Fast Ethernet switch; Fast ethernet maxes out at 100 Mbps, and will automatically drop ethernet frames larger than 1518 bytes (i.e. jumbo frames).
  • The C-5/C-7/C-8 network interface maxes out at 100 Mbps, so it will work fine with a Fast Ethernet switch, and doesn't need a gigabit connection anyway. So connect your Hubitat to the Fast Ethernet switch, and connect the switch to your Verizon Home Internet gateway.

Amazon has Fast Ethernet switches for as low as $10. Here's an example:


Unless every devices in your home has its own public internet IP, you have a router (may be part of your Verizon modem).

If you have a NAS at all, I have seen a lot of people having jumbo frames enabled on those, I would check that first.

1 Like

Excuse me for being dumb, what is NAS? Thanks

Network Area Storage.... So basically if you have a drive array seperate from a pc that is connected via a network interface. This is an example


No I don't have that. The verizon internet gateway is the only thing on the network. Connected via ethernet, is hubitat. Connected via wifi, 2 phones, laptop, desktop, tv, dish, ipad, and microsoft surface.

Check your Verizon routers network setup to see if they turned on jumbo frames