[NEW APP] Room Lighting

When you first import a Scene, I don't think it knows yet what to put in the State column. If you Activate it, it will figure it out.

Just activated it and it didn't update. Reloaded the page a couple of times. Tried using the Activate button on the RL page, and also the activator switch:

First activation:

Second activation:

OK, what happens if you click one of the red circles?

Weird...changes to green/on state, then shortly after changes to red x.

Green, then red...showing this one in green before it changed to red x.

They do report accurately for my dashboard:

It's probably timing out because the blinds don't report promptly -- if they are moving before reporting.

OK, so one of those "as long as it works, don't worry about it" situations?

I turned the activator off and then on again, and now the table is reporting accurately.

1 Like

I transitioned my rules to use room lighting and not sure what I missed but this behaviour seems incorrect. Here's a screenshot.

When TV Time switch is on, living room lights shouldn't turn on. But they have a few times already.

I have both Limit activation and Disable activation when TV Time switch is on, but they keep turning on.

Logs show maybe the illuminance sensor turning them on or the mode change but the conditions above should prevent that.

That's weird. I'll set one up like yours and see what's going on.

Were these on prior to hitting Update or Done in the app? The app is looking for the event of turning on to disable, not the state of it being on.

Great idea, just disappointed how slow it is and the need to refresh everyone you click an option, but I guess that maybe down to limitations of the platform.

Apologies if this has been raised before... Issue with migrating ML to RL where contact sensors are used as triggers.

EDIT - As soon as I make this statement, the Kitchen came through with contact sensors.... Well it's a positive.... Just not sure what I was seeing with my earlier migrations...

I've moved most of my rooms from ML to RL today. Took me a few to work out that I think when choosing to migrate a ML child app to RL, it would appear that migration process hangs when activation based on contact sensors has been selected in the ML setup. Only thing I could see to do was reboot the HE hub, but every chance there was another option. Upon reboot, when opening the parent RL app the migrated ML app is linked and able to be opened, as it would normally when choosing to create the RL app from ML.

When opening the new RL app, motion sensors are the only activation option, but contact sensors are also listed under the list of motion devices selected. Easy enough to remove these, select contact opens as an activation and select the contact sensors under the appropriate list.

A relatively minor migration issue once you know what the issue is, and no reason not to make the move.

Some combination of done and update seems to have solved based on a short test tonight. There was a RM rule also involved so I hit done on that too. I'll need to do a longer test another night. Thanks!

Some combination of done and update seems to have solved based on a short test tonight. There was a RM rule also involved which I hit done again on too.

Edit: spoke too soon.

Same thing, it says disabled by the switch but the illuminance sensor or evening mode are turning the lights on while still supposedly disabled.

Would you post a screenshot of it again, or is it the same as above?

Sorry, I found the problem. It only affected activating by illuminance as far as I can tell. Fix for this will be in the next release.


Fix for this problem with illuminance triggering when disabled has been released: Release 2.3.3 Available - #8 by bravenel

Thanks so much, and amazing turnaround!

I know I've been struggling with RL, and have found a few things that were not working exactly as maybe intended.

But right now at least, all of my RL stuff appears to be working the way I expected it to.

Thanks for speedy responses!

1 Like

Hi! I'm new in here Hubitat world and maybe I'm stupid or blind, but I can't find the way to install this room light app? Thanks for helping me out!

Try going to the Apps page and selecting new built in app.

1 Like

Of course, like I said, I'm stupid, :grinning: Thanks!