Need to set a parameter with z-wave advanced command (Fibaro Dimmer)

Hi, i tried to figure out how to use the send command in device page for my Fibaro Dimmer that is using erocm123 drivers. I need it so that i force calibration due to i have a bypass connected.

I tried to look into the driver code on how it should look like but still no luck.

Happy new year!

Have you tried the "Basic Z-Wave Parameter Tool"?

Install this driver then temporarily set your device to it. Report output shows up in the logs.

Also Happy New Year to you as well!!! :confetti_ball:

4 Likes

Assuming you are referring to the Advanced > Send Zwave Command, it requires the full zwave command data as a hex string and sends it to the device.
If you are comfortable with the risks involved, it looks something like this:

Configuration Command Class: 0x70 (from zwave spec)
Configuration Get Command: 0x05 (from zwave spec)
Command takes 1 byte: The parameter number (from device documentation)

So to get the configuration for parameter 13, the encoded command would be something like: 70050D

The result (per spec) of ConfigurationGet will be a ConfigurationReport sent to the device handler (which may or may not be ignored or logged).

Details on encoding the commands requires an understanding of the zwave spec and knowing the command classes (and command class versions) supported by the device.

The basic z-wave tool is much easier to work with. :slight_smile:

5 Likes

Thanks for the tip, downloaded that tool and think it worked.

When i ran it.
bild

I saw this in the log:

The lamp did turn on and off like a "calibration step"

Cheers Dawid

2 Likes

I’m trying to achieve the same as the OP.
I loaded the basic Z wave tool.
Set parameter 13 to size 1 and value 2 but the log shows the value as 1 not 2.

I have a fibaro dimmer2 and a fibaro bypass.

How do I force parameter 13 to a value of 2?

My issue is led lights are flickering when on the lowest dim setting.

I've found the same. Regardless of whether you send value 1 or 2 for parameter 13 with Basic Z Wave Tool- the logs report that parameter 1 was sent. I'm not sure where the issue lies. I'd imagine that the Z Wave Tool is correctly sending a value of 2 and that the Fibaro is responding value 1 regardless. I have 14 Fibaro Dimmer 2's in my setup - some with and some without the bypass. It would be nice to know that the Basic Z Wave Tool is sending the correct command for option 2 'with bypass fitted'. Otherwise it's necessary to take the switch off the wall to access the button on the module which is a PITA.

I have about 12 fibaro dimmers and have only just installed one today with a bypass so the switch housing is still open. What do I do with the B button to force the parameter change? I know 3 quick presses are for joining to my z wave network. Where can I find out the other button press configurations? I don’t think the parameter is changing to 2 because my lights are still flickering

From memory:

  • for calibration without a bypass installed. Press and hold the button on the module. When it turns blue, briefly press the button again

  • for calibration with a bypass installed. Press and hold the button on the module. When it turns red, briefly press the button again

If your lights are still flickering after you've calibrated. You may need to mess with other parameters and I'd start by manually raising the minimum level from its calibrated value to a higher value (you can use the Z wave tool to read all the parameters while you've a log page open. Some LEDs work better than others for dimming. If found that after calibration my downlights would dim down to minimum, but when I switched them back on again using the switch at that level, only one or two would come on until I set the dimmer higher.

Thanks. So I did the calibration with the bypass. The lights still flicker between 1% and 7% dimmed. So I’ll try changing the lower dim threshold so it can’t go below 7%. Failing that, I’ll just try some different LED bulbs.

Quick question regarding the bypass. I have two sets of lights on one switch and the bypass is on just one set. Do I need a bypass on each?

The way it works is that the calibration sets a minimum and maximum level that the Dimmer 2 will use. You can see those values when you read the parameters with the Z Wave Tool. For example one of my sets after calibration was 12 minimum, 85 maximum. When you set a level from Hubitat, you will still use 1 to 100. Those levels of 1 to 100 are applied within the calibrated range of 12 to 85.

One bypass should be fitted per Dimmer 2. Any switch connected to a single Dimmer 2 should bring all of the lights on. You shouldn't have a situation where the Dimmer 2 supplies more than one switch such that not all the lights turn on/off together.

If you haven't already I'd recommend downloading the full manual for the Dimmer 2 which shows the possible configurations.

1 Like

So I downloaded the dimmer2 manual and the parameters make sense now. The auto calibration had minimum brightness at 1 and maximum at 45. Through trial & error the minimum value for my led bulbs stops flickering when set to 10. Increasing the maximum value caused flickering so left that at 45. All is good now. Thanks for clarifying.

My other half has just told me she wants different lights in the room now ( non led) , so the bypass won’t be needed. :roll_eyes: But this was a useful learning exercise for me.

1 Like

If those devices support Configuration v3 or higher command class you might be able to scan and display all the parameter using this new tool I am testing. It works pretty good provided the mfg has useful info stored in the firmware.

2 Likes

LEDs can be pain with the dimmer modules as you've found. Even though the lamps are detailed as 'dimmable' you can often find that they won't reliably dim as low (or as high) as they would with a rotary dimmer. Another thing you'll find is that sometimes they're not very linear. That is, they will increase brightness slowly then suddenly speed up. You can play with the parameters on the Dimmer 2 and I found tweaking parameters 5 through 8 gave some improvements. Those parameters alter how big each dimming step is and the time it takes to move through each dimming step. You can have different settings for automatic (digital command from Hubitat) vs manual (at the switch)

If you're going to use them with non LED lamps such as halogen capsules etc; be careful not to overload them as it's a pain. If you overload it, it cuts out and tries again a few times before just flashing an error on the module and you've got to try and get the lamps switched on and immediately lower the level to prevent the overload.

1 Like

@johnwill1 many thanks for your help. Yes, got to note the wattage. I did once overload a dimmer2 with 2 halogen light fittings each fitting had 5 bulbs. The dimmer just refused to work so ended up using 2 modules and a switch for each.

Thanks, How does this differ from the badic z wave tool?

The Basic ZWave tool just allows you to manually set a single parameter when you know the number and size already. For my driver, if the device supports it, it actually asks the device about all the parameters, discovers all the parameter numbers and valid ranges. After that it asks for a title and description of each parameter. Once it has all the info it can show you all the parameters at once, with the current values set, and you can then make adjustments and save. If you look at my post I have an example screenshot.

Got it now. Thanks for explaining

Download the Hubitat app