Need assistance determining if hub is off network

I am tryng to figure out an issue where my hub don't connect to hub app. I have been working with habitat support, and they have asked a question that I'm not sure how to get the answer. I have asked for clarification, but I'm a little antsy about this. Here us what they asked:

> I've noticed that the hub reports an IP address upon boot but there's always a delay between it booting and connecting to the cloud. Do you see it being off the network for 1-2 minutes immediately after reboot?

How would I determine if it's off the network immediately after reboot? Near as I can tell it is, but is there some kind of tool I can use to make a defined determination?

For reference: The hub is a C8, attached by ethernet cable to a POE switch. It is the only one of three (the other two are C7's) That I am having this issue with.

Hub Information Driver v3 - dnsStatus:
image

If you have a PC, Mac or Linux system that can reach your hub, you can open a command prompt or terminal window and send a continuous ping to the hub. You need to know your hub's IP address.

Windows - ping with the -t or /t option. ping 10.x.x.x -t for example

Mac - should automatically run a continuous ping using just the ping command. ping 10.x.x.x for example

Linux - Same as Mac

Start a continuous ping. Reboot the hub. You should see the ping fail while the hub is booting and then respond once the hub is online. You should be able to watch the hub reboot in a browser window along with the ping in the command prompt or terminal window. Once you see the hub has rebooted, watch the ping and see if it responds right away or if there is a delay.

Hub needs to be up for the OP to see that info.

He needs to be able to see whether his hub is active on his network immediately after a reboot.

Just needs to set a rule to check on restart and alert. The driver is usually active before you can view the UI.

Yes, but again, the hub needs to be up and on the network for that. That will not tell the OP if there is a delay with the hub connecting to the network after a reboot.

Actually it doesn't, it just needs to have completed the reboot. Services, drivers and apps are normally fully operational a good 10-20 seconds before you get the UI.

So OP should see the continuous ping drop and then resume right after the hub reboots. If there is any issue, then the ping resuming would be delayed. This should, to me, provide a better confirmation of a issue. OP does not have to rely on the hub to send a notification.

Of course, OP is free to use any method he prefers. :grinning:

...or any combination thereof. :sunglasses:

1 Like

Ill try both, the experience would be good for me. However,,,

No idea how to do that.

well, could have sworn I already had that installed on this hub, but I guess I don't, and I can't get it from HPM. It won't install. Do you happen to have a URL to import it from?

Am I doing this correctly?

https://raw.githubusercontent.com/thebearmay/hubitat/main/hubInfoV3.groovy

1 Like

If I do Just ping 192.168.XX.XXX it get a response. If it add -t or /t after I get

Ping request could not find host 192.168.50.220/t. Please check the name and try again.

You need a space.

ping 192.168.50.222 -t

or

ping 192.168.50.222 /t

1 Like

Im gonna guess this may be part of my problem?? I don't even have a dnsStatus

Enable polling for Extended Network Data

This?
image

Still not showing. Also clicked, Save, Configure and Update after selecting this. I have tried setting to each, 1-4. dnsStatus still doesn't show up, Im really starting to believe have a defective hub.

Under settings DNS was set to 9.9.9.9 (that must be the default, I never set it. I added 1.1.1.1, though I doubt that would make much of a difference.

ahh ok. that worked.. when I ran the continuous ping I didn't notice anything off. three failed to respond during the reboot, but other than that, it seemed fine to me.

Ping Results

Now I finally got it to show up. Didnt think to set a poll rate. set it to 1

1 Like

Download the Hubitat app