Nanoleaf Aurora - Can't figure out how to do initial configure

I have seen couple of threads on Nanoleaf, but I didnt see one that spoke about how to do the initial configuration with HE. As such, it must be very simple, but I am overlooking whatever it is that needs to be done.

I created a virtual device -Nanoleaf. At first I though it would have to do something like enter a username and password, but saw no way to do that. Then i thought maybe I needed the Nanoleaf IP address on my LAN, but entering that doesnt seem to allow control. My guess is that it has something to do with the GetAuthToken button, but not really sure what to do with that. Can anyone point me in the right direction?

Thanks in advance!

Enter the ip address of your nanoleaf in the driver ui, then press the link button on the nanoleaf, then within 15 seconds, click save preferences.

1 Like

thank you. It took me a few tries, but after pressing and holding the power button, putting it into what looked like a pairing mode, it was able to work!

1 Like

sorry, i am new to hubitat and still didn't understand what you mean can you please add step by step instructions? what do you mean put the IP in the driver UI what is the driver UI?

Go to devices, then add virtual device.
In the type drop down, select Nanoleaf Aurora, Enter a name for the Aurora, then save device.
Enter the ip address of the Aurora, press the pairing button on the Aurora, then within 15 seconds click save preferences in the driver ui.
It should then populate all the current values.
If this doesn't happen, verify the Auaora ip address, place the Aurora in pairing mode and click save preferences again.

1 Like

thx, now it's working :grin:
but don't understand yet how to choose different light scenes

Any chance support for Nanoleaf canvas will be added?
I get the following when trying to pair:
dev:3222019-11-02 01:37:08.850 am errorstateSet error status:408

dev:3222019-11-02 01:37:08.850 am errorstateSet error status:408

dev:3222019-11-02 01:36:49.985 am warngetAuthToken failed, place Aurora in pairing mode!, hold the power button until it begins flashing, then click getAuthToken.

dev:3222019-11-02 01:36:39.896 am warndescription logging is: true

Canvas is supported, I have one.

You use the setEffect(number) command.
In rule you need to use run custom action.

Okay, I seem to be having trouble pairing it...
I put it in pair mode (holding power and dim until it flashes) (which also unpairs it from my cell).
Then I click 'save' in hubitat - and it gives me an error retrieving authcode...

I'll reset it and try again.


If you hold it too long it factory resets the thing, thus unpairing it from the nanoleaf app...


Thanks - yeah, I think it must have been 'holding to long and resetting'.
I actually only pressed the power button for 7 seconds this time until it started cycling through the commands - then it was able to pair, and grab all the scenes.
Now I'm off to buy another set of nanoleafs!

I don't see where to add the IP address?! Help please?

A link to instructions on adding this device are three posts up.

Thanks for the quick answer! Maybe I am using the wrong driver? Under preferences I do not see ip address

well that isnt a driver I recognize...
from the instruction link I previously referenced:

  1. Use the NanoLeaf Smarter Series app from your mobile device to setup your light panels on the WiFi network.
  2. From the Hubitat Web Interface home page, select Devices , then Add Virtual Device
  1. Name your device and select Nanoleaf Aurora from the device Type drop-down menu, and press Save .

Thank You for the help! My mistake was loading some custom driver instead of using the one already included! I am now up and running and am able to pull up the stored scenes in the Nanoleaf Aurora.

I'm a new Hubitat user and have had great fun setting up my WeMo devices and building some simple automations around them. However, I've hit a wall with setting up my Nanoleaf Aurora panels. I've followed the instructions above many times and followed the advice in this thread, with as many variations as I can think of, and I simply cannot make it work. The step that always fails is when I press (or, rather, hold for a few seconds) the Nanoleaf pairing button and then click Get Auth Token. The log always shows this error:

"getAuthToken failed, place Aurora in pairing mode!, hold the power button until it begins flashing, then click getAuthToken."

As I say, I'm a new user and so is it possible I'm misinterpreting and instruction or overlooking something obvious?

Thanks for any advice you might be able to offer!

Sorry for the super slow reply - but that's similar to what I had, and the problem on my side was just holding the power button too long - so I'd miss the window for the token... Did you ever get it working?