Multiple "Simple Automation" Apps After Upgrade

I'm hoping someone can help me get my Hubitat back on track. I'm trying to update my C5 to the latest version after years of not upgrading. The software installation goes okay, but afterwards I'm left with many "Simple Automation Rules" apps (among others) that I can't seem to get rid of.

I have a problem that is very similar to what is described here (but this thread is closed and no solution is provided in the thread):

The rules that currently exist no longer work (and editing the rules gives a runtime error). I've tried a soft reset but it didn't make a difference (I still see the same apps available).

Does anyone out there know how to solve this (or perhaps do a hard-reset on the unit)?


Can you do a soft reset on the unit? Then restore from backup?

Hi @rlithgow1 , thank you for responding!

Yes, I should have included this on my original post. I tried a soft reset (and a restore) to no avail; the problem persists.

I wish I could attach a screenshot of what I'm seeing. Basically I have 4 "Simple Automation" apps visible to me, none of which work (or can be removed from the interface manually).

Any other ideas?

To post screen shots join the owners group here Hub owners - Hubitat

That said, if you go to the rule and see a gear icon, click the gear icon, then scroll to the bottom and click remove.

Outstanding. I've joined the group, here's a screencap of what I see in my application list.

I'll follow up later this evening when I'm able to try removing the apps again (I believe I either get an error message or they just don't get removed). Stay tuned...

oooooooh now I see what you are saying now. I was thinking it was a rule issue.... Dumb question. Have you shutdown from the settings menu, unpluged for 1 minute and brought back up?

Also what diagnostic tool is showing on your diagnostics page at yourhubip:8081 ?

Here's what I'm seeing in the diagnostic tool:

I can't see to remove the apps (since they're built in). Three of them lead me to a broken page like this (with JavaScript errors in the console):


One of them shows an error like this:

Any ideas on what to try next?

I think I might have been there at one time.

I think it might have something to do with the Simple Automation App being revised, or whatever, and your rules are now obsolete.

I kind of recall having to recreate the rules, or something like that.

Good luck.

Did you do a full power down and reboot? Hmm... To @velvetfoot 's mention, how many Simple automation rules do you have? ( mean the rules not the app)

A crapload.

lol I meant @user6309 sorry.

1 Like

Yes, I forgot to mention that, shutting down, unplug and rebooting was the first thing I tried yesterday.

I only have 4 simple automaton rules. I only have a handful of devices (a few switches, outlets and my garage door opener). If I have to, I can rebuild from scratch. I just can't find the "Factory Reset" instructions anywhere.

Ok backup (export) the individual rules, then delete them. Reboot and see if the issue resolves

Done. Still no luck, when I got to Add Built-In App I still see 4 "Simple Automation" apps. Only the one "works" but it gives the same error message:

App type with namespace: hubitat and name: Simple Automation Rule 1.2 has parent type that does not match current app

FWIW I also see multiple "Motion and Mode Light Apps" in the Built-In Apps list.

I found the previous version I was running: (which I believe was ancient).

I think that's your problem.
Your rules are ancient.
They're living in the past, man, to paraphrase Eric The Clown. :slight_smile:

Is there any way to purge them? They seem to survive a "Soft Reset". (I have removed all the actual rules I configured, it's the entries in the app list that seem to be problematic.)

If you remove the rules and its still coming back, I think it's time to get @support_team tagged in this.

Can you remove the old SA child app?
The app, not any rules.

They survive because when you restore the backup, you restore the same apps too... A Soft Reset removes the internal database, then when you use the restore function, you load the same database that was running before the Soft Reset. I am sending you an private message to get more details about your hub.

When I go to Create a new SA rule I get the version number below.