Multiple Hue Dimmer Switch Issue

Hi all
Im running the latest HE firmware ( and have 2 Philips Hue dimmer switches. I seem to only be able to get one dimmer switch paired to the hub at any one time with the native drivers. The first dimmer pairs ok and as soon as I then pair the second dimmer the first one stops responding. Re-pair the first again and the second dimmer then gets knocked out.
Anyone else getting this same behaviour?

Hmmm. Interesting. Most of my Hue Dimmers are attached to the Hue Bridges instead for historical (and mostly 'can't face changing it') reasons.

However... I've got a couple in a box here. Hang on. Let me see what happens.

-- Jules

1 Like

OK. Well... I can confirm that HALF of that works for me.

Specifically... I added one dimmer. Fine. Watch the logs, and it's working. Added a second dimmer, and watched the logs. That one's working.

HOWEVER... the first dimmer them stopped working. Removed the device... reset the dimmer, re-added it... and now both of them are working properly.

So... I'd say there might be something up there, but I, at least, have managed to get both attached at once and working.

Sorry I can't try with 3 or more. I've got other dimmers, but they've got a job to do :wink:

If you can't get them working, or things get even worse with more than 2 dimmers, I'd raise a support ticket - it looks to me like there could be something up there, because adding the second one definately knocked the first one out for me as well.

It's a built-in integration, so we can't even look at the source to see if we can eyeball the problem.

-- Jules

1 Like

@JulesT thanks for confirming you are getting the same issue. I havent tried removing, resetting etc for the first device after adding device 2. I will give that a go and see what happens for me. lol my 3rd dimmer arrived today :grimacing: (part of an Amazon offer - hue motion sensor + dimmer for Β£5 less than the motion sensor by itself). When it knocked out the first device for me I just tried the reset (hold the button in for 10 seconds) on discovery screen and got a message saying the device had been found and was being reconfigured. I will raise a support ticket still - at least it can be looked into so that when fixed it doesnt happen to other HE users.

I know it may be unrelated, but with the Hue motion sensors a custom driver was needed to pair the device, because the stock driver had issues with the initial paring. Once the device was paired I was able switch back to the stock driver and the device would work as intended.

Yeah. Having paired my two additional controllers to Hubitat directly, I'm starting to think that I might be better off re-attaching them to another Hue Hub. It's probably unrelated... but while just trying to bang some quick rules in to actually wire up the buttons (on, off, dim, etc)... the hub itself has suddenly become dead slow. Might be related to the 7 or 8 new lights I just added, and it'll probably snap out of it eventually (I've found that if you add enough new stuff in a row, things get slow for a while), but to be honest, it's probably simpler to let the Hue bridge run them for now. It's not like I need the buttons for anything more general - I was just trying to keep the hue device count down to defer having to get bridge #3.

-- Jules

PS. In the time it took me to write this note... the hub obviously digested whatever it was chewing on, and is now back to being nice and snappy. Phew.

Can someone with two of these try this?
Add the first dimmer, confirm operation...
Remove battery from first dimmer
Add second dimmer, confirm operation...
Insert battery in first dimmer, confirm operation of both dimmers.

I should be able to give this a go later when at home. Just delete both dimmers first and reboot the hub?

there isn't any need to reboot, and as for removals, just remove the last one.
I've never seen anything like this before, just wondering if the second one is telling the first one to get lost, or the first one is somehow deciding to leave on its own when the second one joins.

1 Like

Hmmm. well... curiously... I can't get either of them to respond now.

Time to blow 'em away and try again, I guess. I'll have a bash after dinner.

-- Jules

@JulesT same for me too. I haven’t done the instructions yet that @mike.maxwell said to perform but neither of my switches are working now - I did however do a reboot in the day time. Wondering if that could be the issue? Did you do the same Jules?

As it happens, I DID reboot my hub today... but that was before I played with these.

The first device was paired prior to the reboot, though... and that was still working before I added the second.

Right. Got both switches back in front of me, rather than in the far reaches of the house... so I'll do as instructed. So much for the button configuration I'd stuck against them.

-- Jules

Right... So... @mike.maxwell - tested as you requested - from NEITHER device registered... registered the first... checked it worked... removed battery, registered second device... checked it worked. Added battery to first device... and now they both work.

I'm now going to leave them for an hour or so, and see if they STILL work.

Hope that helps!

-- Jules

Ok. My last update for the evening. Controller #1 has dropped it's connection. Pressing buttons yields a red light, and that's it.

#2 is still working.

I left them both alone for a shade over an hour - something's clearly not right here.

They're both within 6 feet of the Hubitat hub itself, in case that's relevant to anybody.

I'll check back in with them tomorrow.

-- Jules

OK so I've given it a go myself too.
Had to blast both devices - one of them just flashed the red light 3 seconds after any button was pressed (light stayed of for 3 seconds) and the other button flashed red and green a few times straight away when any button pressed - nothing showing in any log for either. Before blasting either device this was the device screen:

Performed @mike.maxwell instructions from post 7 and both work correctly just likes Jules is getting. Will also give it an hour and try again (log files looking fine when any button pressed)

Just tested and both dimmers working still an hour later. I will see how they are tomorrow and perform a hub reboot

And first thing this morning, both dimmers are declining to speak to me.

Something's not right here. I wonder what it is. I think there's an older, community-supported driver somewhere. I'll try them tonight and see if they work any better.

-- Jules

For me both summers are working still since removing battery and pairing everything from new

And mine aren't. How odd.

Ah well... It's no great loss for me. I'll re-add them to the relevant hue hubs, and hang the device limit. The Zigbee signal from the hue bulbs will be stronger in that part of the house anyway. :wink:

-- Jules

I lost control of both of the dimmers after each of the recent updates - for me it seems like a update/reboot is what kills bother switches