Motion rules for GE Link 22604 not working

I am trying to automate my basement lights with a motion sensor.

I have an Aeon Multisensor 6. and my lights are GE Link 22604. My motion sensor is sensing temperature, motion, etc and is functioning fine which i verify in the logs. My lights also turn on and off via the Device web page.

I setup a Motion and Mode lighting rule to turn on the lights with motion and turn them off after 1 minute. Under the "Lights to turn on" I have tried both the "Set the dimmers" and the "Turn on switches" but neither of these options are ever turning off the lights. And the lights never go off if they are on.

I am a bit stumped because the exact same ruleset is working for a motion sensor and smart outlet.

any help/suggestion is greatly appreciated.

Are you able to control your GE Link bulbs from their device pages?

Sorry, I missed the sentence in your post indicating the lights can be controlled via the device page.

Have you added the bulbs individually to your Motion & Mode lighting rule? Or did you create a group of the relevant bulbs and use the group device instead? If you created the group, did you turn zigbee group messaging on?

initially I added the bulbs individually and that didnt work. now i created a group and that doesnt work either.

From the Devices webpage both options work for turning the bulbs off and on.

Can you post a screenshot of your mode & motion app? Thanks!

Welcome to Hubitat, @cmd41par!

What driver (device type) on the device's setting page is this using?

1 Like

To eliminate a variable, could you try the following:

  1. Create a virtual motion sensor, and replace "string sensor" with the virtual motion sensor (in your motion lighting app)
  2. Keep a log window open, and in a separate device window, click the active button for the virtual motion sensor.
  3. Post the logs.


1 Like

i assume you mean the below - Advanced Zigbee bulb


Ahh. Had they paired as "Advanced Zigbee Bulb", or had you manually set that to be the driver?

Can you try changing the driver to "Generic Zigbee Bulb"? After doing so, click the "Configure" button on the device page.


Thanks this worked. I changed the driver to "Generic Zigbee Bulb" for all three and it seems to be working.


Glad to hear that worked.

Can I suggest you still consider grouping the bulbs that will be controlled together. Turn on "zigbee group messaging" for that group, and use the group device in your automations.


thx for this.

The GE bulbs ultimately seem pretty unreliable with these simple automations. They would work for a while and then not respond and then I had to join them again.

Unfortunately, these GE bulbs are not very good zigbee mesh routers. There are ways to get them to work semi-stably, but in general they require some baby-sitting. Most people prefer replacing them with bulbs that work well out of the box (eg. bulbs by Sengled, or Innr). There are also really inexpensive zigbee 3.0 RGBW bulbs made by eWeLink sold under a variety of brand-names that work well with Hubitat. I wrote a review on them a while ago.