Motion lighting issue, thinks light is on when its not

Hubitat 2.3.0.116. At some point in the past few upgrades Motion Lighting instances started not turning on a light when when expected. It appears to be when the light is off, but the app thinks its on so skips the action, leaving me & the SO in the dark.

Here is an example rule:

The switch has been off since 3:59, and is physically off:


The associated motion sensor went off at 5:14:56 and should have turned the light on, but didn't:

This is picked up by the motion lighting app, but that decides not to turn on the light because it thinks its already on:

This seems wrong. Other examples behave the same way. Is this a bug or do I need to somehow configure things differently ?

Thanks

Open the ML instance and hit Done. That may correct it.

Thanks for the suggestion, no joy unfortunately.

I had the same thing happen to me after the last update. It only happened on 1 of many motion rules. I just deleted the rule and recreated it and it fixed it.

Thanks for the suggestion but no joy.

Oh well Rule Machine still works.

I've been seeing this same behavior since upgrading to 2.2.9.146. Hitting "done" would fix a rule for awhile but the problem returned. One night, motion lighting was ignoring the disable switch in the bedroom rule when my wife was trying to go to bed. Not good. Hitting done fixed it. I did a soft reset the next day and that seemed to fix motion lighting issues for good. No issues after that.

I updated to 2.2.3.116 and all was good for a day until this morning when the bathroom light quit. I hit done and it started working. Definitely something going on with motion lighting (or the database after an update). I'll probably just do another soft reset tonight.

Download the Hubitat app