Mode Manager Not Changing

Since the last update to 2.13.120 mode manager seems to be stuck in Day mode. At sunset -30 minutes it is supposed to change to evening mode. Nope. At 23:45 it is supposed to change to night mode. Nope. Up until the update, mode manager has functioned perfectly. System time is set properly and nothing else has changed. Rebooted hub and changed night mode to be a few minutes in the future. Did not change.

Try opening Mode Manager and hitting Done. See if that gets it working again.

It got it working for changing from Day to Evening, but then it got stuck on Evening. Rebooted and it made it through a change from Evening to Night to Day and then got stuck again. I had multiple other issues with 2.13.120 so I rolled back as I could not get HE to update no matter what I did. It is stable and working again on the previous version.

You should be on

I've been having a similar issue with it not changing some modes. Seems that the modes that are set to change on certain days are the ones not changing, (see "Early-Weekday" and "Morning-Weekday" in the screenshot below).

I am on but I was on the previous release when the global endpoints issue was happening. I reverted to to get my Amazon Echos working again, but went straight from to last night.

The two "selective day" modes did not switch correctly going straight from Twilight to Day this morning missing "Early-Weekday" and "Morning-Weekday". I rebooted my hub, went to Mode manager, opened and hit "done", then rebooted again. I also enabled logging to get some additional info to troubleshoot with.

Hopefully that does the trick, but I won't know until tomorrow morning. I will post an update if it still is not working.

So this morning, "Early-Weekday" did not switch, but "Morning-Weekday" did. The logs show no entry of Hubitat switching to "Early-Weekday". So I'm not sure what's going on.

Do all days have to be defined when using Mode Manager?

I've defined "Early-Weekday" for Mon-Fri at 4:50a, but I did not set a time for Sat or Sun. Could that be my issue?

"Morning-Weekday" is set the same way but that one seems to be working.

I will investigate this issue. Not sure what is going on. Could you post screenshots of you app status page. Find that with the gear icon upper right in the app, or just left of the app in the Apps list.

Awesome! Thank for your help, @bravenel. The status page for mode manager is below.

There's more to it than that one screen shot. Need to see the whole thing.

Click on it @bravenel, it is the full thing, it is a scrollable screenshot with all values just capped by the view

ok thanks

@bravenel, thank you for looking into this.

So here's something strange. This morning, it switched into "Early-Weekday" but then did not switch into "Morning-Weekday" or "Day" modes.

After looking back through the status page you asked for, I noticed references to "Weekday-Early", "Early-Weekend" and "Morning-Weekend".

I remember setting up modes like this initially when I first starting with the Hubitat, but thought I removed them in Modes and Mode Manager. They aren't currently listed in Modes (see below) or Mode Manager (see previous screenshot).

Could these be leftover entries that are conflicting within Mode Manager? Is there a way to manually remove them even thought they aren't listed?

Thanks again.

Those are simply old settings, not used anymore. Ignore them unless you want to remove and redo Mode manager.

Update: So over the weekend I decided to try removing Mode Manager, rebooting, adding MM back and recreating the schedules. This morning it still did not change into "Early-Weekday", but did go from "Twilight" to "Morning-Weekday".
But I also noted something else this morning. In the past logs, the mode manager is reporting "Evening" on the log screen, even though it's in "Day" mode and shows day mode on the Apps screen.

I am completely unable to reproduce this failure. All I can think of is to add more logging to the app, for example to log when it doesn't switch to a mode because of it being the wrong day.

One more request for information. Open the app status page like you did before, and click on Events -- show that page. And while you're at it show the Scheduled Jobs section of the app status page itself again.

This only reflects the setting at the time that particular log was started. The green text is added to the app name, and the app name is shown in the logs. Even if the app name changes due to a mode change, that log heading will stay the same.

@bravenel, yesterday, I did confirm in Mode Manager, that there was a pending scheduled job for 4:50a, to verify that MM should trigger the next morning. But this morning when I woke up, I found it had again, not switched into “Early-Weekday” mode.

In my frustration, I decided to abandon MM for a 4.0 Rule I created a couple of days ago and had on pause. (see below)

I created this rule as a “plan B” if a resolution was never found for MM. Since my mode changes were on a schedule and not very complex, it was easy to write. Also, it gives me much a much more verbose log to work with, should it fail for some reason.

But since MM does not have a pause button, I removed it so it would not conflict with the rule. Ergo, I don’t have the screenshots you asked for to post. But over the last few days, I have combed through both the events, (which showed no entries for timeframes when the “Early-Weekday” should have triggered), and the scheduled jobs, (which had pending entries for 4:50a, when “Early-Weekday” was scheduled).

Hopefully this new rule will shed some light on the issue and find a cause for MM not triggering. If not, at least it’s a work around.

I appreciate your work on looking into this and thank you very much. If I could ask one more thing, please take a look at the rule and let me know if it can be cleaned up in any way or a better way to write it.

You can always disable an app on the Apps page. Click on the gray X in upper right corner, then a column appears that allows an app to be disabled.


Wish I'd seen that before. I may reload MM in that case and further test what may be my issue. But for now I'm going to let the rule run and see if it turns up something new.

Thanks again @bravenel

There is unlikely to be any light shed on the MM issue from using RM, as the two are completely different. The next release (2.1.4) will have a bit more logging in MM, which may or may not shed some light on why it was failing.

I did a soft reset, and then restored per the suggestion from support for my hub slowdown issues. Now mode manger is not automatically changing modes, and slowdowns are still happening. I did open MM and click done, we will see if it changes this evening.