Mode doesn't change from Away

I'm starting to wonder if my inability to grasp the term "Mode" is part of the problem. I'm looking at the app list, and I installed the Mode Manager and tried to figure out what a mode is and how you make one. So far, I've failed. But I did read that "Away" is a special mode, that does what I want to do: change the state of the house when I leave and resume a schedule when I return. So: in the app list it says "Mode Manager Away". Does that mean I have one mode and its called "Away". Or does it mean that The mode "Away" is currently active? The word "Away" is in green. Maybe I've just got a perpetual away mode which would explain why my presence does not wake up the thermostat.

I opened up the Mode Manager and see what's shown below. The first instruction is almost completely incomprehensible to me. What does "not when mode is Away" even mean? Does it mean "when you are home?" And "Modes not to change from: Away" is an un-parseable sentence fragment that makes my eyes cross. It's almost like a double negative. This mode business is killing me. Can someone explain whether my thermostat won't turn up when I return because it thinks it's in Away mode regardless of what my presence fobs indicate?

And do I have conflicting instructions here:

Set modes based on time of day (not when mode is Away)
Modes NOT to change from: Away

Set modes based on presence
Use time settings for return from Away for All of Dusty Fob 4B, Guest Fob 4B, M2 Fob 4B, Rhiana 4B arrives Away: All of M2 Fob 4B, Rhiana Fob 4B, Dusty Fob 4B, Guest Fob 4B leave

1 Like

Ah, thanks for pointing how the difficulty in understanding this. We will improve the documentation.

Usually, you will set your modes based on time of day. But, you will usually set Away mode based on presence (the absence of anyone being home). The "not when mode is Away" means don't set the mode based on time when we are Away. That wouldn't make sense. When you're Away, you want the mode to remain Away until you return. Then when you return, you want the mode to become whatever mode it should be based on what time of day it is. So "not when mode is Away" and "Modes NOT to change from: Away" are the same thing.

Great. That's exactly what I want. But it's not working. It can figure out I'm away, but can't figure out I'm home. Two questions:

  1. Does this mean I have one mode called "Away"? Or does it mean "Away" is the active mode?

If it's the second, why doesn't it know I'm home? All my presence fobs show present on the dashboard.

2.) Are these two rules conflicting?

On the "Use time settings for return" you should check Any, not All.

I'm going crazy. It is set to any. I don't know why it's different in the screen shot. I think I have a gremlin in my system. Can you possibly answer my first question above? Am I in Away mode? Or is green text simply a design device? I cannot progress until I understand this.

It looks like you are in Away mode. You can always see your mode and set it on the Settings / Location and Modes page.

That display where it said All was a bug. It will be fixed in our next release.

Ah, A bug. I'm not crazy. So, it is set correctly, but it still never changes from Away when I get home. I'm still having this problem. I'm looking for help with this right now over on the IRIS transition thread...

Could you show your entire Mode Manager app page. Also, have you looked at the device events for your presence sensors?

In frustration, I deleted the entire Mode Manager App. LOL. Solved that problem! Seriously though, csteele gave me enough hints on how to do Away & Return from Away with Rule Machine that I am going with that for now. As my rules get more complex, If it seems like I want to switch back to Modes, I'll resume this inquiry. Thanks to everyone for being out there!