Mobile app won't start. Anyone running the mobile app on an Oppo F11?

The mobile app won't start on my wife's Oppo F11 Pro. It just sits at the flash screen. Have tried all the normal approaches of deleting cache, data, and reinstalling. No joy.

Same problem here, Oppo A9 2020. Sits at the flash screen for ever. Must be an Oppo thing then? Anyone have any ideas how to solve it? This phone is my daily driver now, and not having app support is getting a bit frustrating...

Seems like no one in support is at all interested in hundreds of thousands of people in Asia not being able to access their app....

The app is a joke anyway.
From this perspective, Hubitat is light years away from SmartThings.
Automating things in your home is not enough.
You need to be able to manage sensors at any point in time (from anywhere), to make changes if needed, etc. They just load dashboards in some sort of frame and name it a mobile app. If you design the dashboard for a tablet or monitor, it's not going to look well.
They will feed you with workarounds like creating separate dashboards for your phone...
If they need pitching for this kind of stuff, they don't understand the market.

Such as what?

Have a look at SmartThings app, even at HomeAssistant.
Compare them with Hubitat app... if you can make it start on a phone. :laughing:

I'd rather my wife throw away her Oppo than use the SmartThings app lol.

Although it is damned irritating there has been no response on this issue @bobbyD

I'm having the same issue. Just migrated from an old OnePlus 6T (where the app and push notifications worked fine) to a new Oppo FindX2 Pro (not a budget device and not just sold in Asia) and the app seems to get stuck on the initial splash screen. As with others I've cleared cache and data and reinstalled. But no luck. I need this for push notifications(only) to the mobile device. Hoping someone from support can assist with this if the community hasn't found a solution (that doesn't involve changing phones, lol)

BTW, of the hundred or so apps that I have on this new phone this is the only app with any sort of issue

Also disabled power-management for the app but that didn't help

I can't speak to the app compatibility with your device. However if notifications are the only need there may be other options that will work for you.

The built in pushover integration is pretty popular.

There is also a driver for the join api which is what i personally like.

1 Like

Ditto.

It is still damned irritating that there is still no response on this issue @bobbyD

So an update (that was quick). I was in the middle of installing pushover (thanks cwwilson08) to solve the issue when I noticed the phone was warning me of the Hubitat app using power in the background (as I had explicitly allowed background activity for that app). Clicking on the warning opened the Hubitat app from the background and the normal first time app screen appeared... I was able to login and select the correct Hub and notifications are working. This took about an hour before the background app notification appeared. The only other thing I did prior to this was to manually allow the three permissions that were in the denied list (Cam, Loc and Phys). I've since restarted the phone to confirm the operation with two results. Firstly notifications continued to work after the restart with no manual intervention. However, if you need to open the app for any reason its still stuck on the splash screen after the restart. I'll leave it running in the background and report back if it opens again in an hour :slight_smile:

Clicked on the app again after a couple of hours and it opened straight away and worked perfectly. So its getting stuck on something at start and finally times out and opens (maybe). If I close it again and reopen its the same behaviour (stuck on the splash screen). Hope that helps the devs of this app. I'll reiterate once again this is the only app that I'm observing this behaviour from on the phone and there are no other issues. I performed a factory reset of the phone before installing anything so its fresh. Its not rooted, factory Oppo ColorOS 7.1(Android 10 SP 5th Oct20), Snapdragon 865.

Exactly, all the other apps work just fine. So please don't blame the device!

New user here, just received my HE yesterday and am looking to get started ... was browsing the community and saw this topic about Oppo phones and the app issue. Figured I'll give it a try on my Oppo Find X2 .. well, guess what, I've got the same problem! Nice :frowning: :frowning_face: