Milight / easy bulbs

Yeah, give it a whirl. I think you just enter rgb for the type and it should work. Ill change the string to ColorControl. I took that from some example I found.. so that too may have been old/wrong.

Changed it to ColorControl and still works :slight_smile: So now I will play with figuring out how to set an initial value so there are no NULLs and possibly saving the latest color for reference.

Got out my RGB bulb to test, and it works perfectly!
I've merged your changes in - if you make any other additions feel free to send a pull request :slight_smile:

The driver works perfect. However when paired with the voice control with google home is limited to temperature only but not RGB. With amazon Alexa the RGB control is working fine as well temperature control.
Since it is working with Alexa, I hope there is a way to fix it to work with google home as well.

Thanks! Got ESP and setup.

I can control lights great from ESP directly via web, but can’t get hubitat to control ESP :frowning:

Got ip address of ESP and Hub ID. Is Hub ID on hubitat and Device ID in ESP webpage the same thing?
I have also tried changing remote/light type (rgb_cct) and group ids.

I got MQTT with ESP setup and working though.

Any ideas?

1 Like

Yes Hub ID / Device ID looks correct.

On your screenshot of the light in Hubitat, you have the IP address as Get rid of the http and slashes - it should just be the IP:

Perfect that worked thanks.

Regarding remotedriver (hubitat_driver_esp8266milighthub/remotedriver.groovy at master · cometfish/hubitat_driver_esp8266milighthub · GitHub) what is the status of this app?

Would you be able to write up a quick readme?
I have installed it and keen to control my blinds via hubitat from my milight remote.
Haven't figured out how to set it up yet.

I got so far as establishing the connection.

The remote driver should be working, though yes it's lacking in documentation.
You need to set the "MQTT update topic pattern" setting on the MiLight hub to: milightupdate/:device_id/:device_type/:group_id
... and then fill out the light group settings in the Hubitat driver for the remote id, type of bulb, & group number to listen for (0 for the All group, or 1/2/3/4).

(Note: the wheel buttons on the remote are not yet supported; only the on/off buttons will work.)

edit: fixed topic group code

Ok, and what goes in the MQTT client ID field? Cant find any client ID on the ESP webpage.
I tried:

  • milightupdate
  • milight/status
  • milight
  • hubitat_milight

I'm looking for anything in logs when pressing the remote button.

Just a unique name, for this particular connection to your MQTT broker.

If you're not seeing anything, I'd suggest subscribing to all topics on your MQTT broker (from your computer), press a button on your remote, and check that the message is appearing there in the format you expect (same device ID, type, etc).

Great. Figured out I had to use these two fields with different topics for it to work. Otherwise would be in a loop of receive transmit.

I'm now seeing it in my MQTT explorer, but still nothing in hubitat logs :frowning:

Did native UDP direct-to-Device support ever get added for this? It looks like everyone is using Christopher Mullin’s gateway to communicate with the devices.

The bulbs run on 2.4Ghz radio frequency, they don't use UDP. (The gateway has a NRF24L01+ module attached to be able to talk to the bulbs.)

Right. Does the WiFi -> 2.4 bridge not use UDP anymore, though? I recall using the Limitless interface on these 5-or-so years ago with good results. It also appears Home Assistant's integration uses socket to talk to the bridge.

Thanks for the screenshots - you've set the wrong field to the milightupdate topic :slight_smile:

Sure, the official bridge allows you to use UDP to talk to it.
The milight gateway is a total replacement for the bridge: it talks directly to the bulbs.

For me the bridge kept freezing up, whereas the milight gateway has run for months with no issues.
It also allows you to support as many remotes as you want to - the bridge is limited to one set of four light groups (ie. one remote).
And of course, it's open source, so you know it's not sending data back to base, and there's less chance it's vulnerable to exploits.

1 Like

Ah, cool. Thanks for the clarification!

So - I am a newbie but have this working & Many Thanks.
?is how to use rules to use nightMode
My log from the UI is sending IP/ID/rgbw/2 & works.
Thanks for me missing it if already doc'd.

Welcome to Hubitat!

You need to use "Run Custom Action" in rule machine, like this:

Awesome -instant reply AOK - cometfish
Trust I can be a CIO contributor HE in the Future ... (migrating from ST)
Next is more tipping into Rules, modes, etc.
After that I/O.
Thanks more again CF