MHCOZY $ Channel Relay not pairing

I have a MHCOZY four channel relay. I was going to move it to Hubitat but I can't set it up for pairing. I have tried to search for it and what I found was to do pairing I should push any of the four keys four five seconds. I get a blue solid for about 5 seconds and red blinking every 2 seconds. The blue goes out and the red keeps doing the same as it was. Nothing is found when I try and add a device. I found to reset the device to press one of the four buttons for 15 seconds. I don't know if it did anything, but it still doesn't pair. What do you do to reset and pair? What should the lights look like when set for pairing. I am lost. Thanks in advance for the help.

Examine the box in which the relays board was packed. Is there any label or a check mark reflecting Zigbee?

You may have received a WiFi version by mistake.

I no longer have the box. They have been in use for quite a while and I was changing over to Hubitat. What would the procedure be if it were WiFi?
I believe it was Zigbee. It was set up in Ewelink to begin with, Can you tell me the correct pairing steps, and what the lights should look like if in pairing mode. What would they look like if it had been reset?
Thanks again for the help.

Do you have SONOFF Zigbee hub?
If no, then the board may be WiFi model. Using WiFi with Hubitat is not easy or not possible at all, because every manufacturer has its own proprietary protocol.

Sorry, I also do not remember how did I pair my MHCOZI board to HE.. There is a long thread on pairing this device here : Driver/Pairing -> MHCOZY 4 Channel 12V ZigBee Relay Switch

1 Like

Doesn’t this mean it’s a WiFi device?

2 Likes

I don't have anything with a label that says SONOFF. I reread the article but I don't see anything that states exactly how to pair it with the results that I should see in the lights to show it was ready for pairing. Most devices that I have worked with show a blue and red light blinking opposite to each other but I never see that result with the MHCOZY. It would be helpful to know so that I had the starting steps.

If you don't have a SONOFF Zigbee hub, this means that this relay board has WiFi interface, that's how you used it before with eWeLink mobile app via their cloud services.

I seem to remember that originally it started with Bluetooth and then went to Wi-Fi setup, but I think it may have just booted into pairing mode. The chip ID is PSF-B04, 10014d776d,0485. I pressed one of the four relay buttons for 15 seconds, but I don't know if it reset. I can't find a site that deals with MHCOZY that covers the basics of setup. Most that I find start with "after placing it in pairing mode".

So it's definitely a WiFi model.
You can integrate it into Hubitat via eWeLink cloud-to-cloud services, like IFTTT, Amazon Alexa, etc... Or just buy a new Zigbee version board, these are relatively cheap.

This is the reset procedure, but it will do nothing with HE, as it expects a SonOff proprietary WiFi app to initialize a connection, probably using the BlueTooth channel initially for exchanging the WiFi network username/password and the initial configuration.

I will try both. I will buy a new board, and I will try and integrate the one I have. I will let you know what happens. Thanks.

1 Like

The zigbee versions of these devices pair easily with Hubitat and as a zigbee device, are connected locally.

That is one of my main concerns for most items. I don't want control dependent on the "cloud".

1 Like