Driver/Pairing -> MHCOZY 4 Channel 12V ZigBee Relay Switch

Hi Everyone,
I too have purchased MHCOZY 4 Channel 12V ZigBee Relay Switch and were able to get this paired using the latest HE firmware 2.2.9.129 with HE reconising this device with the 'Generic Zigbee Multi-Endpoint Switch' driver (as expected)
My problem is two-fold

  1. The child devices (3 other relays) are not showing up within the driver settings
  2. The basic on/off button within the driver is not switching on/off the relay

If l change the driver to the Generic Zigbee Outlet, l can switch on/off 1 of the relays, but again the other child devices/relays are not being displayed

Would anyone please have a driver that works this device or is there some sort of trick to pairing this device in order for the child devices to be recognized?

Thanks in advance!

Did you get anywhere with this?

Please see:

Hello everyone,
I just purchased this device (MHCOZY 4 channel relay). It pairs just fine and I used the Generic zigbee multi endpoint switch as suggested further back in this string. I'm having the following problems

  1. I can't control the relay(s) at all
  2. There are no child devices shown at all
  3. I actuate the relays manually no state changes are shown.
    It's almost like I'm using the wrong device type

If I change it to a Generic Zigbee outlet I can turn relay 4 on and off and I can see the state change. I can also see the state change when I manually activate and deactivate each of the 4 relays.

I'm running Firmware 2.3.0.124 on my hub. I'm a little new to this so any help would be greatly appreciated

Thank you

Can you try this driver?

1 Like

Thank You for your help.
When set to "ON" The driver turns ALL the relays on in sequence (1-4).
It does the reverse when set to "OFF"
The state change updates appropriately for the parent
None of the child devices are shown. So they cant be controlled individually.

Thanks again for taking a look at this.

After you changed drivers to "Generic Zigbee Multi-Endpoint Switch", did you click Configure on the device page? It will create the child devices only after that step.

I think you will have to click Configure if you change to @kkossev's driver as well for the child devices to show up.

Hi,
I did as you instructed using both drivers. Pressing configure had no effect on either one. Is there something else I should do after pressing "configure"?

I was wrong. Stand by I think that may have fixed it.

That definitely fixed it. I can now see and control each relay. Thank you and KKossev very much for your help.

You guys are great

2 Likes

@bruceventriglia Is the inbuilt "Generic Zigbee Multi-Endpoint Switch" driver working with your relay board now? Or you are using the driver from the link that I sent you?

1 Like

Hi,
I tried both drivers and they both work fine. Your driver works identically to the Generic Zigbee Multi-endpoint switch

2 Likes

...and thank you once again for your help

2 Likes

Hello,

I have a strange behavior with one of these devices:
They work perfectly when they are "close" to the hub, but when they are further away, they "receive" when I switch a channel "on" or "off" directly on the board, the status change shows up in the hubitat; but I can not control them. When I click "on" or "off" nothing happens.

But when I am closer to the hub, everything works.

I have added a zigbee lightbulb, hoping that it "repeats" the signal. The lightbulb works fine, but it doesn't solve the problem.

Does anyone have any idea? I don't event get any error messages in the logs...

Thank you very much for any thoughts :-)!
Stephan

Only one thought. From the Hubitat docs ....

https://docs.hubitat.com/index.php?title=How_to_Build_a_Solid_Zigbee_Mesh

1 Like

Thank you! Very good idea, let's see if this helps!

1 Like

Which bulb? Many Zigbee bulbs are poor repeaters.

2 Likes

An Ikea TRÅDFRI, but I also installed an OSRAM Smart+ Plug.

As a starter, I now shut down the hub for 20min to rebuild the mesh. Maybe that helps...

1 Like

I hope it does. If possible, view your house as a series of concentric spheres with each radius increasing by 5 ft. Place devices that can repeat at points within each sphere. The points within each sphere don't have to line up with the next sphere.

Thank you very much for all the quick advice! Thank you!!! I will let you know if it works... :slight_smile:

1 Like

Download the Hubitat app