Meross

anyone got to successfully add their Meross smart plugs to Hubitat?
I have 8 plugs and only 2 are working and I did and follow the exact same thing for all of them
here are the logs from both working and not working plugs and the screenshot from the driver, line 139.

I used this driver and method: GitHub - ithinkdancan/hubitat-meross: Hubitat Drivers for Meross Smart Plugs, by @ithinkdancan

thank you!



@ithinkdancan I think he's using your drivers. Any input?

Can you share the model number and firmware versions for each?

1 Like

just noticed that they have different firmware... they are all mss110. The two working with hubitat have firmware version 2.2.4, the remaining 6 devices are 1.1.28 (and I can't update them, I don't know why. I sent a ticket to Meross)

Installed the Outlet Dimmer version of Meross [MPD100]. When I try to control the device using Hubitat I get this error in the logs

When I turn the outlet on and off from the Phone app, I can see it reflect the status on Hubitat. But I cant control the outlet from Hubitat. Any suggestions @ithinkdancan ?

The HE device handler also appears to work on Meross MSS510X (outlet switch). I have 4 installed and they function just like the mini outlet (MSS110). On, Off, Refresh all function.

The driver did not work on the dual outlet plug MSS120B, but I will try again maybe something didn't jive on first try.

PS. Here is the Log for the Dual Plug MSS120B. Not sure what is causing the warning.

@ithinkdancan not sure if this mention is proper. Thx :slight_smile:

MSS120B

Hi.. I was trying to setup a notification using these plugs and noticed this in the log. It happens on all the plugs, so I'm not sure if there is something in the Driver causing this. Appears to occur at the tail end of each actuation of the outlet on/off.

FYI, things are working fine, so I don't know what this is about, but offering it up as a bug (?) to chase.

Hello @ithinkdancan. Are you still supporting this driver? If not please let us know so that we don't bother you. Thanks.

Request failed could mean a number of things. Can you look in the meross app and share the model and firmware number of your device as well as confirm the IP is correct

Model: mpd100
Firmware version: 7.3.6.1.0.2
I have confirmed that the IP address is static and the right one is input in the preferences.

My issue is related to this error

Request failed was another user.

Note that before I became fed up with HomeKit as primary in one of my homes and switched to Hubitat as primary, I had tried Meross HomeKit smart plugs (outlets) and had to return them because they were a MESS (kept becoming unresponsive, wouldn’t pair with HomeKit, etc). So, it may be the outlet itself that is throwing bad stuff at you. If you’re looking for a cheap Zigbee alternative, Third Reality and Sengled have worked fine for me. (Note: TR doesn’t report power). Totally worth not messing with the Wi-Fi driver.

Also, (assuming you use HomeKit and they were working there), have you tried just creating a virtual device in Hubitat to control, using HomeKit integration to send it to HomeKit, and having a HomeKit automation do that same thing on that side. I ddi that previously with a number of outlets, and may be easier than figuring this out :wink:

@bobted i think you added these drivers any suggestions?

I don’t personally own a mpd100 so it’s hard for me to say what the issue may be. Are you using the dimmer device driver

@karnik.abhijeet the error that you are seeing is from the response when the device when turning it on or off has an empty payload. I fixed the code in my HE but never PR'ed it back to @ithinkdancan. I'll get a PR created so that you can get the update.

@ithinkdancan I created a PR with some changes to the dimmer driver. I meant to pull your latest into my fork and create PR there, then create a separate one from my main branch to yours, but I got my remotes mixed up and ended up creating the initial PR in yours.

Thank you @bobted. Please let me know once you have the updated driver.

@ithinkdancan merged the PR into his repo, so it should be available

The error still persists.

My bad @karnik.abhijeet. I patched the refresh response handler and neglected to patch the on/off response handler. I'll get that taken care of today.

Did you try the latest update from 2-Jan?

Gives this error.

Download the Hubitat app