Lutron "telnet support" disabled itself today.... Nothing Lutron was working

I figured out how to set all this up and it all was working for a week but after 2 power losses this morning, there was no control of the bedroom dimmer. I tried to backup from 1-26-2019 and that didn't work. Rebooted both hubs Removed the Lutron bridge and reinstalled it. No luck. until I went through the setup instructions again and then I figured it out... For some reason the "telnet support" disabled itself on the Lutron Hub. Power loss maybe did this? I don't know but it is all working again after turning it back on.
Hope this helps somebody else that is having problems with their Lutron devices.

1 Like

Whenever my power goes out I have to "initialize" my lutron telnet device to get things to work again. I've created a custom rule action to do it automatically.

Being very new, how do you make a rule to do this? What type of event triggers this to reset? Do you have a screen shot of your rule you could post?

That's a little complicated because it involves a power monitor to see if the power has gone and and then come back on and a custom rule action. For now, just go into the edit device page and click "Initialize". The other thing would just confuse you but I'll post it if you want.

thank you. Better than the way I figured it out.....

Power cycle your Lutron Hub? That's the way I first fixed it. :slight_smile:

That didn't work for me. Lost all my button controllers and some rule machine items that pointed to "nothing" when I finally restored the setting to make it work.
Only 2 weeks in as a owner and it is very flexible and very powerful (complex). More than I need, but not limited to devices if you want to program a new driver or find someone who has written the driver on the community.

I flipped my breaker twice a couple days ago to install new Caseta devices, both times Hubitat and the Lutron Bridge came back up on their own with no problems. Is this a common thing? Good to know for future reference...

That is why I posted it. Several hours in, I figured it out so I wanted to save someone else the headache.

1 Like

Happens every time i have a power loss. I posted about it few months back.

You should definitely not lose devices though. They should just be unresponsive from HE. If your devices are getting deleted something else is happening.

1 Like

The devices were lost because I removed the bridge Lutron program from the hubitat. I searched the community and did not find it.

1 Like

I know I did because my Lutron locked up on me several times. It's all together someone flagged it because they thought I was being too rough for their delicate sensibilities.

My advice is get a UPS. APC makes some entry-level ones that have wall mount holes.

Battery backup and clean power are hugely important for a reliable home automation infrastructure. It's not like bridges and hubs draw that much power. So you don't need anything with huge capacity. For me it's there more to provide smooth power, as highs/lows can wreak havoc on power supplies. That and within 2 minutes the backup generator switches over.

Second, in the 5+ years now with Ra2 devices I have never had to restart them. That is, nothing I've ever done with them has gotten them into any sort of locked up state. I have, of course, power cycled them for various reasons, but never because they got hung up.

This makes me think the plug-in might benefit from some added logic to handle connection loss and retries?


I don't think it's so much a problem with the Pro Hub as just the communication between the two. I have my HE and Lutron hub on a UPS but that only lasts for so long. They are going to lose power eventually. You can minimize the impact with a UPS but you still have to have a way to fix it when it happens.

I am monitoring the mains power to my house and when the power has been out for more than 15 minutes (the time my UPS can last reliably) it shuts my hub down. Then when power is restored, it executes a recovery from a power failure. Turning off smart bulbs that always come on to 100%, resetting HSM, and initializing the lutron connection (just in case). Since doing so, I've never had a problem. Now, I don;t know if that is necessary all the time but I have had enough situations where it is that I do it anyway.

Also, whenever I have a hub lockup that "scrambles" the connection to other lan devices (Hubduino boards, wemo plugs) the Lutron is also locked up and requires an initialization. Still trying to figure that situation out completely but still coming up empty so far.

This is interesting. We donโ€™t really lose power where I live, but when I have flipped the breaker my HE hub and lutron bridge are on, I havenโ€™t noticed this issue.

Weird, I'm not seeing this issue at all. Do you have to "initialize" the telnet connection after you do a hub shutdown?

No, it automatically connects.

Sorry, ambiguously worded question. To clarify:

@Ryan780 do you see the same issue after powering back up from a hub shutdown via Settings>Shutdown Hub works perfectly fine then.

Maybe it was a fluke. I have had several power outages in the last week and on subsequent outages, it powered up fine and worked though the next 3 outages. Just an odd thing that somehow happened the 1st time....