Lutron RadioRA2 Keypad Press or Release?

New user here and this could be a newbie issue.

I've setup Hubitat and integrated the App for Lutron RadioRA2. We have a large RadioRA2 setup at our house and I added a few devices manually to Hubitat. I can control dimmers and switches just fine so I know we are communicating with the Main Repeater just fine.

I added a keypad, device 54 to the system and I wanted the Away scene to run from that keypad - which is button 6. If I go into the device interface and "press" button 6, what shows up in the logs is this:
[dev:14] 2019-10-22 14:54:28.128 [info] button 6 pushed
[dev:6] 2019-10-22 14:54:28.063 [info]rcvd: DEVICE,54,6,3
[dev:14]2019-10-22 14:54:27.927 [info]Garage Entrance Keypad button 6 was pushed
But nothing happens in my system.

If I run the Lutron Connect app, and press the Away button from the app, everything works fine. The first "event" that shows up in the Hubitat logs is:
[dev:6]2019-10-22 15:03:53.426 [info]rcvd: DEVICE,54,6,4

Notice that the difference on what is happening on device 54 is in the first instance (Hubitat), it is sending a press command (3) using the Lutron integration protocol. In the second case, the command that is sent is a release - command 4 in the protocol. It appears that the button release is what is driving the event, not the press.

I'm wondering what I'm doing wrong in terms of trying to get this scene to fire by simulating a button press on a keypad. Is there a different way I should be doing this?


Can you show how you have your "scene" set up (presumably just a setting in the HSM app or a rule you created, or maybe you literally have a scene called "Away" on Hubitat--or are just trying to activate a Lutron scene, in which case I'm not sure why Hubitat is involved)?

Also, what is your ultimate goal? I assume you want to press the "real" button on the keypad to trigger this automation, but it's not clear to me since you mention trying only the button in Lutron's app and what I assume is Hubitat's device page for the button but not the button itself (which I hope really does what the app does or you'll have to do a bit of work if you want to be able to use either, but that's a different story).

Could you show the logs for the Lutron Telnet device (use screenshot, not copy-paste). The physical device is sending both 3 and 4, for pressed and released. But, I don't think the scene is activated by released in the RA2 system. If it actually is, that would be the problem. We are about to introduce an update for the Lutron Integration that allows both pressed and released for a Lutron keypad.

Let me be clearer in terms of what I am trying to do. I have a Lutron RadioRA2 scene called "Away". It is tied to a button on a physical keypad close to the entrance to our house. Firing the Away scene from the keypad will turn off all the lights in the house. So, what I'm trying to do is setup a Hubitat rule, and use our phones to fire off the Away scene when our presence is outside the geofence. If I substitute a couple of Lutron switches as action in the rule, instead of a keypad press, then all of this is working fine in terms of the rule engine.

This is the Telnet Log of me physically pressing a button on the keypad -sorry, I tried to post the screen shot but the forum wouldn't let me.
~DEVICE,54,6,4 ~DEVICE,1,195,9,1 ~OUTPUT,21,1,0.00 ~OUTPUT,21,29,8 ~OUTPUT,21,30,1,0.00 ~OUTPUT,23,1,0.00 ...

The only thing I see in the log is the release, then a long list of commands that corresponds to the "Away" scene that is defined in my RadioRA2 system. That is the scene that I want to activate by simulating a keypress (or, a release in this case).

Here is the Hubitat logs for the same activity (note that the log reads up vs. the other log that reads down from Telnet):
[dev:62019-10-22 17:04:54.008 [info]rcvd: OUTPUT,23,1,0.00
[dev:8]2019-10-22 17:04:53.938 [info]Main Hall Cans was turned off
[dev:6]2019-10-22 17:04:53.874 [info]rcvd: OUTPUT,21,1,0.00
[dev:6]2019-10-22 17:04:53.697 [info]rcvd: DEVICE,1,195,9,1
[dev:6]2019-10-22 17:04:53.636 [info]rcvd: DEVICE,54,6,4

Also, just to be clear, this is RadioRA2 Inclusive 12.2.1 release of the software (latest release).

And that info line saying "Main Hall Cans was turned off" is from a Hubitat device I defined that corresponds to a Lutron dimmer (that I can successfully control from Hubitat).

That's very odd, that it doesn't show the ~DEVICE,54,6,3 for that keypad. Please push a different button on that same keypad, and see what is in the Lutron Telnet logs from it.

Could you try an experiment: Open a telnet connection to your RA2 system. Username is lutron, password is integration.

Type in this command: DEVICE,54,6,3

Then see if (a) that activates the Away scene, and (b) what comes back from the system via telnet.

Good idea bravenel. FWIW, from the Telnet prompt you need a # sign in front of the command.

Anyway, #DEVICE, 54, 6, 3 does crickets. #DEVICE, 54, 6, 4 fires off the scene. It sure seems like the release is what is needed for a Lutron RadioRA2 keypad - at least with the latest software. I haven't played around with the Lutron integration protocol in quite some time so I can't tell you whether it worked differently before.

It sounds like your sw release that supports "release" on the keypad will solve my problem. Just not sure why no one ran into this before...

I will have to upgrade my RA2 system, which I have not done yet. I haven't seen this behavior before, and I have many RA2 scenes that are fired by "pushing" a RA2 keypad button, either physically or from Hubitat apps. It may be something that changed in the latest RA2 firmware, don't know.

Very interesting. 12.2.1 comes with some other not-so-nice-to-haves including (silently) dropping support for the Connect Bridge 1. I was an early adopter of the Connect Bridge so have a 1 instead of a 2. It is a strange drop of support since my Connect Bridge appears to still work as before - but it shows up as unavailable (or something like that) from the RA2 desktop software when you update the system. This is reported on the Lutron forums as well, but I didn't see that until after I upgraded. Anyway, I'll either have to buy an upgraded bridge at some point if Lutron won't provide an upgrade.

Anyway, this shouldn't matter for integrating with Hubitat (since you are using telnet protocol) though could trip people up if they delete the default logins on the device - as is suggested on the Lutron upgrade to 12.2.1

I'm certain they will replace it if need be.

We are aware of the logins issue. For now we will deal with that through documentation. As if changing the default somehow makes it more secure?

My keypads (regular and hybrid) only send push events (3) for buttons 1-6. There are no releases. Buttons 18 and 19 (the down and up arrows) do send both push and releases. And that is the spec as far as I know. It will be interesting to see how Hubitat derives a release for buttons 1-6. I'm on 12.2.1 Essentials.

We can't if Lutron doesn't send it. The reason for adding release was to support 18 and 19. But here we have a keypad sending a release instead of a push for button 6, which I've never seen before. The fix to support release will allow this to be used.

I took a quick (not thorough) look through the integration docs and didn't see any device with a 4 as a push. So unless there is some other device that I didn't see the updated app programming seems more of a way of routing around an issue. I would think that all releases would have a preceding push.

@arno - what model keypad is this?

It would be easy to test. I'm thinking this is indeed a release. But, the way to tell is to have a telnet session open, hold the button down, and then release it. The DEVICE,,4 should come then, not on the initial push.

It is a regular keypad - RRD-W6BRL. I haven't checked a hybrid keypad but will and report back what I see.

Bravenel - I opened a telnet session and held button 6 on the keypad. Nothing in the Telnet logs, no response from the system. When I released the button, the log showed the release and then executed the scene.

Also, while I don't think this is relevant, this is an old RadioRA2 system, installed in 2012. Originally started on 5.0.1 software, been continuously upgraded to the latest version of software over the past 7.5 years.

The button in question is tied to a "shared scene" that is my Away scene.

Thanks. I will update my system tomorrow and investigate a bit more.

i wonder if the "Scene Saver" feature - which is an advanced feature of the keypad and turned off by default - is what is causing this behavior difference. i have "Scene Saver" enabled on all my keypads which allows press and hold to save levels after initial programming. It is an advanced option you can control by right clicking on the keypad from the Inclusive software.