Lutron RA2 Select or RadioRA 2 Essentials


#21

There is a trick for this. Pair it to a phantom switch and make Hubitat use the device as the trigger. By phantom switch, I mean a device that is added, paired to the occ sensor, and then physically removed. The switch (which is no longer powered or even in your house) will still have it's state communicated over telnet. Expensive, but if you know somebody who also has Radio Ra 2 switches, it works. There does seem to be a delay though - if you have Hubitat use the Lutron sensor (which is actually the phantom switch) to turn on a real Lutron switch, it can take 3-4 seconds for the action to happen. Seems like the it's an issue with telnet - something is causing a delay.


#22

Maybe I should back up and explain what I’m trying to do in this specific case with Lutron and Hubitat. I have Hue bulbs in a few rooms. I would like to program scenes to Pico Remotes to control the Hue bulbs using Hubitat, including dimmer and color settings. It was my impression that this could be done in Hubitat. Research there led me to requirement to obtain the Caseta Pro bridge. I’m almost at my limit with Caseta devices, so rather than throw more money at Caseta, I’m looking at stepping up to Radio RA2 instead.


#23

Yes, once you have them added to the main repeater Hubitat can talk to them. However, you need to know their "integration id" number. Ordinarily you get this from the Essentials software. There is another method to find the number:

Connect to the main repeater with a telnet session from a terminal app on you PC. Credentials are username: lutron, password: integration. Then hit a button on one of your Picos or other devices. For a Pico you will see a message on telnet that looks like

~DEVICE,12,2,3

The 12 in that example is the integration id. The 2 is which button was pushed, and 3 means pushed.

Other devices may look like this:

~OUTPUT,5,1,100

In that one, the 5 is the integration id. This was a switch turned on.

Then you can setup the Lutron Integration app, giving the devices names, identifying them with the integration id, and selecting what type of device it is. This creates virtual devices in the Hubitat system that correspond to the Lutron devices, and behave accordingly.


#24

Perfect, thanks for that explanation, all clear now... just ordered my HE


#25

Sorry to return here but I've searched high and low, deleted and re-added devices and having no luck. I'm all done with RA2, have Inclusive software, integration report and can setup a 1 Pico remote system (for now), I can see the PIco in Telnet.
image
Set it up in Hubitat:
image
Created a simple automation with the remote:


But the button press does nothing to the lights. I confirmed I can control the lights within Hubitat. It seems like there is a breakdown between HE and Lutron, see below, wouldn't there be activity on one of those (last column)?

I also noticed the DNI for the Lutron Telnet and Devices seems to be changing, I'm pretty sure one of them last night was _89. Not sure if this is normal behavior or not.


#26

It sounds as though your Lutron Integration installation is messed up. Please show a screenshot of the Lutron Integration app, and of its app status page.


#27

Here you go:




#28

And here you go, Lutron Telnet DNI changed:


#29

Adding to this, Hubitat is definitely seeing button press on the Pico, it is logging activity on the device:

But Telnet logs no activity as you can see here:

Not sure if this is normal or not.

I have also tried removing and re-adding Lutron Integration, the device and the simple lighting rule. I also tried moving my Main Repeater, wiring directly into my router (instead of via a few switches). None of this has worked, although I noticed that when moving the Main Repeater on the network, the Pico1 device on Hubitat stopped registering activity until I removed and added it back again.


#30

What is the Lutron Devices device?

I need to see the Lutron Integration app status. Have you given the main repeater a static IP? If not, you should do so. Also, have you tried connecting to the main repeater by telnet? Login credentials are user: lutron, password: integration. You should be able to see the Pico button presses there, and be sure you have the correct id# for the Pico. It will be the first number shown on one of those button presses.

What you showed above was the app status for Lutron Integrator. Need to see for Lutron Integration.


#31

Where do I find the Integration app? When I click the button to install new built-in app this is all I see:

As for telnet, yes I can connect, sent a screen shot of that in a prior message. Button presses are there and I am using the correct id# for the Pico. The Main Repeater is using a static IP.


#32

First you install Lutron Integrator. Then Lutron Integrator will give you the option to install Lutron Integration.

Then you use that to include your Pico and any other devices you want to use in Hubitat.

https://docs.hubitat.com/index.php?title=Lutron_Integrator#Create_a_New_Cas.C3.A9ta.2FRA2_Integration


#33

Ok I got it working. Had nothing to do with the Integrator/Integration. Hubitat Pico button numbers are different from Lutron - I had the simple lighting rule set to buttons 2/4 on/off and Hubitat sees them as buttons 1/5 for some reason. I found the Hubitat button number under Pico device - Events. Will rely on that events page to guide me on button numbers going forward. Thanks for all of your help!