Lutron Pico Remote: Direct Association & Accessing in Hubitat


I have a 2 button Pico Remote that I've associated all Lutron devices directly to via the Lutron App. This essentially creates an 'ALL ON' and 'ALL OFF.'

I have the Pico Remote imported into Hubitat. Is there a way to use that remote to mimic the physical pushing of either an 'ALL ON' or 'ALL OFF.' I couldn't figure out a way to make this happen because it looks like when either button is pressed, there's a "push" immediately followed by a "release." Example below:


The Pico works like any other button device in Hubitat. Go to the Hubitat Pico device page and "push" one of the buttons. It will do what you've programmed on the Lutron bridge.

You don't need to rely on a Pico to control those actions. Hubitat can activate any scene that is programmed on the Lutron bridge (100 scene capacity). See this recent thread:

1 Like

@salieri disconnect the pico from all the lights in the lutron app.

Create a scene on the lutron app called ALL LIGHTS OFF. Tell the scene to turn all lights off (obviously :slight_smile: )

On hubitat in the lutron integration put in a line that says K, 1, whateveryouwanttocallthe device.. I called my Smart Bridge Pro Scenes

Now run the integration report on the lutron app and note the device number of the ALL LIGHTS OFF scene...

Under button controller create a button using the pico controller that calls the keypad number (scene number) it will set like this. Pushing that button number in Smart Pro Scenes will activate the scene on the bridge and turn off all your lights without popcorning...

1 Like

Thanks to both for responding, appreciated.

@rlithgow1 - Brilliant, thank you. One of your previous posts made me realize I was using the Lutron Pico Remote architecture inefficiently (I was having Hubitat perform turning the lights on/off when it saw the Pico button 1 or 2 pressed).

I ran into this snag once I associated the devices directly within the Lutron app to the Pico Remote. Doing a "push button 1 or 2" from the Hubitat device UI was not working. I guess something else is expected to make this work.

Will give this a go, thanks.

1 Like