Lutron Pico buttons ignored

Hey, everyone. I'm struggling to get Hubitat to respond to a new Lutron Pico remote I've added. I have paired it with the Lutron Hub (pro) by using the Lutron phone app, holding the button in for 10 sec, etc. I have added it to the list in the Lutron Integrator:
p,3,Bed Pico
p,4,Family Room Pico
p,12,Kitchen Counter <--- here
s,2,Front Porch Light

I have assigned actions to the buttons.

All seems ok to that point, but no devices or rules respond to the new button. The log shows only this:
[dev:135] 2019-06-20 04:58:46.925 pm [info] rcvd: DEVICE,12,4,4 (push and release a button)
[dev:135] 2019-06-20 04:58:46.771 pm [info] rcvd: DEVICE,12,4,3
[dev:135] 2019-06-20 04:58:44.264 pm [info] rcvd: DEVICE,12,2,4 (push and release another)
[dev:135] 2019-06-20 04:58:44.036 pm [info] rcvd: DEVICE,12,2,3

If I press another Pico remote's button (this pico was set up long ago), I get the actions correctly:
app:146 2019-06-20 05:01:06.459 pm info Family Room Lights All Off Triggered
dev:135 2019-06-20 05:01:06.455 pm info rcvd: OUTPUT,7,1,0.00
dev:137 2019-06-20 05:01:06.351 pm info Family Room Lamp 2 was turned off
dev:135 2019-06-20 05:01:06.311 pm info rcvd: OUTPUT,6,1,0.00
dev:136 2019-06-20 05:01:06.284 pm info Family Room Lamp 1 was turned off
app:146 2019-06-20 05:01:06.193 pm info Family Room Lights All Off: Family Room Pico pushed 5
dev:132 2019-06-20 05:01:06.082 pm info Family Room Pico button 5 was pushed
dev:135 2019-06-20 05:01:06.057 pm info rcvd: DEVICE,4,4,4
dev:135 2019-06-20 05:01:05.909 pm info rcvd: DEVICE,4,4,3

I restarted both Hubitat and the Lutron hub. No change.

What I do notice is that in the Lutron settings list, but not in the application state list:

Finally, if I look at the device list for that Pico remote, it doesn't show any state variables, while other Picos show states "1: 0" thru "5: 0".

I must be missing something in registering the Pico remote?

Thanks for the help!

So you’re using the button controller app or @stephack β€˜s ABC? Are you using the fast Pico driver? Not all devices support that.

Thanks for the reply. I'm not using any specific driver, beyond the Lutron Integrator. I have tried installing the Button Controller, but it still isn't responding to Pico button presses.

Then, in devices, I use the Pico:

This is the device properties for an older, working Pico:

This is the non-working Pico:

with the non working pico
delete the counter light bc rule
click remove device (delete the device)
in the Lutron integration, remove p 12 (the kitchen counter pico), save (done) that, then re open and re add p 12.
about the only thing i can think of on this, while the pico is sending the correct data to hubitat, the lutron integration isn't sending it to the pico driver for whatever reason.

1 Like

Finally got back at this. Thanks for the advice. It took a couple of tries and a couple of reboots to get it to work. In the end, I did this:
-switch bc rule to another button (avoids deleting rule)
-remove device
-remove p 12... from lutron integration list, save (done)
-restart both Hubitat and Lutron hubs
-add p 12... to lutron integration list
-restart Hubitat
Now pico showed up in device list
The first time I didn't restart the hubs, and it didn't work. Did two separate restarts (not sure if I needed both), and it worked.
Thanks again for the help!

Thanks for this. Just had a similar issue.

Simply deleting the button and then adding it back with a new rule worked.