Lutron lights turning off automatically after adding a new device/rule

Hi all,

I have a Lutron Caseta integration with about 20 switches that has been working flawlessly for about a year or more. I have several indoor/outdoor switches which I turn on at sunset and turn off at sunrise using Simple Automation Rules.

I recently added a Lutron outdoor switch to the system for holiday lights and it works as expected. I added a Simple Automation Rule to turn it on at sunset and turn it off at 1am which works as expected.

The problem is ALL my other switches now turn off at 1am too. I did not change any of their settings but for some reason they are turning off. I have checked the Rules for them and nothing is changed as they all are scheduled to turn off at sunrise.

I have checked the Lutron app to see if there is something in there but no automations in there either.

Any suggestions on how I debug this to figure out what is triggering all the lights to turn off?

Thanks in advance for the help.

Brad

Could the problem be related to this?

I only have Picos and one Lutron plug but I put all of my Picos in the "Pico" room and the plug in the "Repeater" room after reading this thread or another similar one.

Thanks for the tip. I have the plug in my Front Porch room in Lutron and there are no other devices in that room. Also, the switches that are turning off are not Picos but actual switches. Not sure if that matters but wanted to add more info.

Do you have any scenes created in the Lutron app?

2 Likes

Any chance that when you added this new device to Hubitat, that there was a typo made in the Lutron Integrator? Just guessing... :thinking:

2 Likes

I have 3 scenes in the Lutron app. But none of them involve one of the switches that is being turned off at 1am so I wasn't thinking it would be something with Scenes. Let me know if you think otherwise.

I am totally open to the idea but what would the typo be that would cause that? I can turn the new device on/off individually and it doesn't affect any other lights.

I just checked the Integration ID and it is the same in the Lutron app and the Integrator. Other than the name and type of device, there isn't anything else to set.

1 Like

If that's the case I'd be looking in the logs at 1am to see if something else is causing this.

Okay, then in that case, it sounds like it is configured correctly.

Perhaps try deleting the new automation that runs at 1am and recreate it again?

Ok, probably a stupid question but when I look at the logs, I only see the events that happened in the morning starting around 7:30am. It doesn't go all the way back to 1am.

How do I find the events that happened during the night? I scroll all the way to the bottom of past logs but there is no next page or page 2 or anything.

Brad

Great idea. I had thought about deleting the automation entirely and seeing if it happens too.

What browser are you using? Chrome seems to work best for most things. Once you click Logs, select the "Past Logs" near the top of the page, and then scroll down. At the bottom of the page, you should see "Show More" that can be clicked.

The log file size is limited, thus if you have a lot of logging from devices, you may be limited in how far back you can go. My advice would be to turn off Debug Logging and Descriptive Logging for all devices that are 'working properly' (i.e. those you're not trying to debug an issue for.) They will still log real errors, but it can drastically clear up you Logs to be able to see the truly important things.

Note: You can also disable logging in Rule Machine, as well as some other apps, if they are clogging up your logs.

Thanks for the tip. I do not see a Show More at the bottom so I guess I am hitting the limit. I will turn some things off as you said.

I did delete the Rule and devices still turned off at 1am. Also, I forgot to mention, one of the devices is not a Lutron switch so that should rule out a problem with Lutron and limit it to Hubitat.

Will delete rules one by one to see which one is causing the issues.

Brad

It may not be a Hubitat issue. Do you use Alexa or Google Home?

4 Likes

Yes, I use Alexa. How does that factor into it?

In the Alexa app on your phone, look for any Alexa Routines that may have been auto-created by Amazon. These are listed as 'suggestions', but are sometimes easy to click on and accept without realizing what one has just done.

Also, go into the Alexa app's settings and make sure "Hunches" are disabled. Otherwise, Alexa will try to 'help you' by making making a hunch as to what it thinks you might like to have switched on/off at various times of the day.

3 Likes

HOLY COW! Thank you @ogiewon! That was it. Alex had automatically created a routine to turn the lights off at 1am!

2 Likes

Download the Hubitat app