LoraTap 6 button controller drivers?

Hi to all Hubitat users!

Here I come again with another Tuya based button switch.

  • endpointId: 01
  • application: 40
  • softwareBuild:
  • driver: v0.8.2.0925b
  • inClusters: 0004,0005,EF00,0000
  • outClusters: 0019,000A
  • model: TS0601
  • manufacturer: _TZE200_2m38mh6k

HE does find it, but I’ve tried the available drivers and all of them create 1 child button only and it doesnt work..

Tried these drivers so far:

  • Markus Zemismark Zigbee Button Remote
  • Tuya Zigbee Scene Switch - built in (this is the one that works with the LoraTap’s 3 button version), but I had no luck making it work with this 6 buttons version.
  • Xiaomi

Ideas?

2 Likes

Check with @kkossev, he has done some great work writing drivers for some of the tuya devices.

You can try this driver, probably won't work but worth a try.

1 Like

Seeing the inClusters list of this device, I can't recall an existing HE driver for it...

Can you post some debug logs when you press the 5th or the 6ths button? (use any driver that has 'Debug' option)

P.S. You can use the 'Hide details' when posing long logs - like this:

Summary

image

1 Like

Hi @kuzenkohome !
Thanks for the help.

Using the driver allowed HE to map 4 child buttons.

But apparently none of them will work... Logs show nothing at button press....

Hey @kkossev !

I changed the driver to your Tuya Scene Switch TS004F; enabled logging; cleared the log and pressed CONFIGURE.

This is the resulting log after 5 min of waiting.

Pressing any of the buttons does nothing at the log page.

Remove the batteries, wait 1 minute and power the remote again.... Anything in the logs?

This is a 'sleepy' Zigbee device, so pressing Configure will not do anything, except the device is awake at the same time... because a button was pressed at the same time as an example.

If removing/resinerting the batteries shows nothing in the logs, please re-pair the device again to HE with this driver.

Hi @kkossev !

I tried removing and powering on the remote, nothing on the log.

Removed it from HE, re-paired using Tuya Zigbee Switch driver. Pressed the 6 buttons, nothing logs (the LED on the remote lights up).
Pressed config 2 times to see if it would show, and it shows.

Removed the battery and powered it... nothing

Seems iike the remote is not paired to HE at all ..
What I can suggest is to REMOVE the device from the web UI, then remove the battery, wait a longer time (4-6 minutes) to make sure the device is reset, then pair it again to HE. There should be something in the logs, no matter what driver is used.

When you pair it as a new device, there will be a 'link' shortcut on the web page (before you enter a device name and press Save). Can you copy the device details text from this link?

Hey @kkossev
Sorry for the delay, took me a while to get back home.

This the pairing log:


After that, pressed all the 6 buttons, and nothing shows.

Removed, repaired:

Thanks for the help so far!!!

Unfortunately, I can't find much information for this device on the Web...
We will have to wait some time until more info is available. At this time, I have no more ideas why the controller stops sending any data after the initial ZigBee pairing.

Thanks for the effort @kkossev !

@gusthepenguin can you try the development branch version of TS004F driver (the link is in the second post in this thread)?

Hey @kkossev !

Sorry, I can’t help you!
I have returned both of them….

1 Like

Download the Hubitat app